1.75 / 20.00 tps


I run a SkyFactory3 server. I’m running SpongeForge 1.10.2


  • World Edit
  • Grief Prevention
  • Sky Claims
  • Luck Perms
  • Rank Upper
  • Admin Shops
  • Nucleus

I’m having awful lag on the server. At the time of writing this, I have 1.75 TPS.

How can I find out what the problem is? The lag is really awful.

There are some upcoming performance improvents that should help improve your TPS.

In the meantime, can you run and screenshot the output of WarmRoast (expand the nodes fully)

Is there a tutorial on how to use WarmRoast? I don’t really understand how to use it.

I’m using CreeperHost as a host, by the way.

Do /sponge timings paste and give us the output (have players online for at least 5 minutes prior to the command, doing their thing). This will give a detailed analysis of performance for the server.



Here is another one where the server wasn’t as laggy.

Couple o’ issues there: Forge is not updated to SpongeForge, so please use Forge 2221 (if in doubt, always look at what the second number in the sponge jar says… it’s the Forge version that should be used). While you are at it, please update to the latest Sponge Forge. Keep in mind that plugins like LuckPerms therefore need to be updated as well. GriefPrevention seems to have problems; what version are you running?

Overall, seems the server has issues with entity ticking… which aren’t solved as easily. In your sponge.conf, navigate to the entity-activation-range and set auto-populate to true. Once you’ve restarted your server, you will see the listing get filled with different mobs from your countless modpack. Stop the server after the list is sufficiently full (tip, it checks the mobs that are new and adds them to a list), and then drop the range numbers for all mobs. This can be done by simply modifying the existing listing’s values. Try first by half (eg, 16 to 8), and save the config. Restart the server - you should see performance increase now.

Let me know how it goes!


First off, thank you for your help.

I did what you said to do in the second paragraph in with the auto-populate stuff.

Here is my new timings report: Aikar's Timings Viewer

I am a bit confused about what you mean in the first paragraph about Forge not being updated to SpongeForge.

And for grief prevention, I’m running griefprevention-1.10.2- What problems specifically are you noticing with Grief Prevention?

The FluxNetworks version in SF3 is super buggy and pretty much killing your server performance, disable/update it.
See [1.10.2] TPS issue - 1.1.1 · Issue #54 · SonarSonic/Flux-Networks · GitHub and Performance · Issue #50 · SonarSonic/Flux-Networks · GitHub

I haven’t tried the newer version yet, I just disabled the mod on my servers, but the mod dev said he fixed it.

I’ll just disable it. Is there a specific way to do this?

I went into flux_networks.cfg and here is what I found:

I don’t see a specific way to disable it via the config.

The other option I thought of was to just delete the FluxNetworks-1.10.2-1.1.1.jar file. But, if I deleted the mod .jar file, wouldn’t players who are trying to join get the mod rejection screen?

Please let me know the best way to disable Flux Networks.


  • Vigilius

Nah, if you delete it people can still join. Keep in mind this will probably break a bunch of peoples bases if they rely on the mod for their power! You will also have to run /fml confirm from the console after deleting the mod jar to confirm the removal of all blocks/items from that mod in the world.

I deleted the mod .jar file and typed /fml confirm into the console and it said 13:23:35 [Info] Unknown command. Try /help for a list of commands

Why is it showing up as an unknown command?

try with and without the slash?

Nope. Same thing. Any idea why it’s an unknown command?

no, this is a command build into forge, was it maybe already confirmed/can you join the server?

I deleted the mod, while the server was online, went to my console without restarting or stopping the server, typed the command /fml confirm, got the invalid command error, and restarted my server. When I did this, the server would start normally. However, the server would almost finish starting up completely and it would say invalid block ids and then proceed to shut its self down. Note: It didn’t crash, it specifically said in the console “Stopping Server”

After the server repeatedly shut its self down, I put the mod back in the mods folder and everything started back up as usual.

Please let me know if any of those steps are incorrect/out of order.

stop server, delete mod, then start it up and run /fml confirm after the missing blocks/items message
it doesn’t shut itself down if it did there’s something in your setup doing that