Anytime I start the server up with a sponge plugin, it crashes

The pastebin for the error: http://pastebin.com/kXrHdKHQ

Looks like your plugin is trying to use a class that doesn’t exist (org/spongepowered/api/service/ProviderExistsException).

Have you tried installing another plugin?

This looks like you’re using a plugin that hasn’t been updated to the latest version of Sponge. Make sure you’ve updated all of your plugins.

Try updating your Sponge Version too, you’re running a fairly old build.