Configurate is saving nodes surrounded with quotes

@line 76-81. It only surrounds the node names with quotes if they contain certain symbols like “_”, so I don’t know what I should do.

You mind checking this out, @zml?

Is this actually an issue? I can’t speak for HOCON but in YML this was normal and fixed syntax issues.

Well, it really doesn’t need to happen for underscores. It acts up sometimes when it has quotes, I’ve noticed.

Whenever there is a special character or spaces, HOCON will automatically wrap in double quotes. I’ve not had any issues from it. I’ve stored UUIDs, Encrypted strings, booleans, ints and others. I don’t believe there is anything wrong with it. Also, it makes it easy to store empty strings by setting the value to “”.

Not an issue, this is how the language escapes certain values. Hocon is a bit overly quote-happy in some cases, but it shouldn’t cause issues. Also, “it acts up sometimes” does not count as a valid bug report :smile:

Yeah. This is more of a “how can I get this to stop doing this” but it isn’t doing what it was last night anymore :3