Could luacs1998 fix the compatibility of sponge with other coremods?

Pull request for 1.8
Pull request for 1.7.10

The author of ForgeEssentials, luacs1998, made two pull requests for fixing the compatibility of coremods with sponge.

But unfortunately, the Forge Mod Loader change have not applied to MinecraftForge yet (The submodule hasn’t updated yet). Does this really fix?

You can always build it yourself if you need that change.