[delete] delete

So, I know I can’t be the only one who programs during their free time at work (or maybe more… <.<)

Currently, I am running into a snag regarding pulling down the Minecraft dependencies through Gradle, due to firewall restrictions. In the past I have used tools like Proxifier and ProxyCap paired with a personal DreamHost server connected through PuTTY to circumvent this, but unfortunately the trials for those have run out, and I don’t particularly feel like paying $45 for it.

How do you guys go about situations like this? Currently I’m looking into potentially just using Remote Desktop Connection, but that’s pretty much my last idea.

I know he problem., I can access stuff but gradlew doesnt like working through a proxy so although i can download gradle itself gradlew cant get anything.

It would be fantastic if the dependencies were stored elsewhere, on a site not tagged as gaming, nor a site that most companies tag as “dangerous” such as cnet or SourceForge.

At work we use Maven normally so that isnt blocked its just gradle wrapper cannot work through a proxy and needs to be directly connected so i had to take my laptop out of the office and install the code and workspace from home then after that it all works ok.

Yeah, my personal laptop has it working, but I’d just rather not have to swap between that and my Desktop.

Also, I envy thee with an actual programming job… Soon hopefully. :stuck_out_tongue: Until then…

Have you tried turning it off and on again?

Good news! You can configure gradle to use a proxy by configuring a few variables. See:

http://www.gradle.org/docs/current/userguide/build_environment.html

@Riizu Not being able to pull dependencies is tough otherwise though. Are you allowed to bring in third party flash drives, or connect to a website you can upload to? I’m not sure if this will work, but you could try to copy the relevant files (the entire ~/.gradle/caches/ directory) from your laptop to the appropriate location at the firewalled computer. Don’t forget to tar/zip. :slight_smile:

There is an issue with Gradle Wrapper not working through a proxy even with the proxy settings.
It is fixed in M9 but forge uses 1.8 so doesnt support it …

https://issues.gradle.org/browse/GRADLE-1679

Wait… that issue is over two years old; the 1.0 M9 fixes surely must’ve been inherited by the 1.8 wrapper by now? What’s going on in your case? The same errors as in that ticket? Do any of their solutions work (like editing gradle/wrapper/gradle-wrapper.properties)?

By the way, drop by #ForgeGradle and ask Abrar about it; he might have a pointer or two.

If you are able to use your laptop at work (they are both available simultaneously) you can always use something like Synergy to share the mouse/keyboard from your workstation. Your laptop more or less acts like a second (third? fourth?) monitor which just happens to be running off a different machine…

Not really a solution, but I do this often. It can be useful to compile something on one machine and leave all the processing open on the other. Or keep some files on a private machine. Etc.

I had tried something similar, copying the “build” folder out of my install, but unfortunately the laptop is also a mac, which has made it a little harder to find the /gradle/caches directory.

The network etc prohibits hosting things like that, even on an internal basis. My network is a bitch :stuck_out_tongue_winking_eye:

You can always do a system wide proxy or vpn (Hotspot Shield, I don’t like it though). Or, just setup a ssh server on your home network and just ssh -D 8080 computer@home

As I have stated in another thread, my Maven repo is available (and gradle can make use of maven repo’s for dependencies). http://nexus.theyeticave.net/content/groups/public/ It should allow you to bypass the whole “This is a gaming site so NO” problem that you are having. If there is a specific common dependency that you cannot get there let me know and I can find it and add it in. It already proxies most of the big stuff like codehaus and maven central as well.

I personally use my Minecraft server as a personal SSH tunnel. As long as you have an SSH server at home and a SSH client on your system, you can tunnel :slight_smile:

Do you mean you host your Minecraft server off of *nix and use that? Or the actual server itself…?

I host my Minecraft server on a dedicated Linux system that also serves as an SSH tunnel

This would be great! Is this just a setting in my build.gradle file? (For reference, currently using this with ForgeGradle and all that, but shouldn’t be terribly different functionality wise)

EDIT: Modified the “maven” section to your listed url, this was the error message I received.
FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'LetsMod'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not find net.md-5:SpecialSource:1.7-SNAPSHOT.
     Searched in the following locations:
         https://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7-SNAPSHOT/mave
n-metadata.xml
         https://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7-SNAPSHOT/Spec
ialSource-1.7-SNAPSHOT.pom
         https://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7-SNAPSHOT/Spec
ialSource-1.7-SNAPSHOT.jar
         http://files.minecraftforge.net/maven/net/md-5/SpecialSource/1.7-SNAPSH
OT/maven-metadata.xml
         http://files.minecraftforge.net/maven/net/md-5/SpecialSource/1.7-SNAPSH
OT/SpecialSource-1.7-SNAPSHOT.pom
         http://files.minecraftforge.net/maven/net/md-5/SpecialSource/1.7-SNAPSH
OT/SpecialSource-1.7-SNAPSHOT.jar
         http://nexus.theyeticave.net/content/groups/public/net/md-5/SpecialSour
ce/1.7-SNAPSHOT/maven-metadata.xml
         http://nexus.theyeticave.net/content/groups/public/net/md-5/SpecialSour
ce/1.7-SNAPSHOT/SpecialSource-1.7-SNAPSHOT.pom
         http://nexus.theyeticave.net/content/groups/public/net/md-5/SpecialSour
ce/1.7-SNAPSHOT/SpecialSource-1.7-SNAPSHOT.jar
     Required by:
         :LetsMod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSH
OT

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.

BUILD FAILED

Total time: 3.845 secs

EDIT2: Here would be my associated build.gradle :stuck_out_tongue: Figured that may help :stuck_out_tongue_winking_eye:

buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "http://files.minecraftforge.net/maven"
        }
        maven {
            //name = "sonatype"
            //url = "https://oss.sonatype.org/content/repositories/snapshots/"
			name = "yeticave"
			url = "http://nexus.theyeticave.net/content/groups/public/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

apply plugin: 'forge'

version = "1.7.10-1.0"
group= "com.riizu.letsmodreboot" // http://maven.apache.org/guides/mini/guide-naming-conventions.html
archivesBaseName = "letsmodreboot"

minecraft {
    version = "1.7.10-10.13.0.1170"
}

dependencies {
    // you may put jars on which you depend on in ./libs
    // or you may define them like so..
    //compile "some.group:artifact:version:classifier"
    //compile "some.group:artifact:version"

    // real examples
    //compile 'com.mod-buildcraft:buildcraft:6.0.8:dev'  // adds buildcraft to the dev env
    //compile 'com.googlecode.efficient-java-matrix-library:ejml:0.24' // adds ejml to the dev env

    // for more info...
    // http://www.gradle.org/docs/current/userguide/artifact_dependencies_tutorial.html
    // http://www.gradle.org/docs/current/userguide/dependency_management.html

}

processResources
{
    // this will ensure that this task is redone when the versions change.
    inputs.property "version", project.version
    inputs.property "mcversion", project.minecraft.version

    // replace stuff in mcmod.info, nothing else
    from(sourceSets.main.resources.srcDirs) {
        include 'mcmod.info'
                
        // replace version and mcversion
        expand 'version':project.version, 'mcversion':project.minecraft.version
    }
        
    // copy everything else, thats not the mcmod.info
    from(sourceSets.main.resources.srcDirs) {
        exclude 'mcmod.info'
    }
}

EDIT #3: Added a new maven code block, for a seperate repository. Got much farther, but still error’d out with my original errors, issues with pulling down from minecraft.net it looks like.

FAILURE: Build failed with an exception.

* What went wrong:
Could not resolve all dependencies for configuration ':compile'.
> Could not resolve net.minecraft:launchwrapper:1.9.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/net/minecraft/launchwrapper/
1.9/launchwrapper-1.9.pom'.
      > peer not authenticated
> Could not resolve lzma:lzma:0.0.1.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/lzma/lzma/0.0.1/lzma-0.0.1.p
om'.
      > peer not authenticated
> Could not resolve com.mojang:realms:1.2.9.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/mojang/realms/1.2.9/real
ms-1.2.9.pom'.
      > peer not authenticated
> Could not resolve com.ibm.icu:icu4j-core-mojang:51.2.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/ibm/icu/icu4j-core-mojan
g/51.2/icu4j-core-mojang-51.2.pom'.
      > peer not authenticated
> Could not resolve com.paulscode:codecjorbis:20101023.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/paulscode/codecjorbis/20
101023/codecjorbis-20101023.pom'.
      > peer not authenticated
> Could not resolve com.paulscode:codecwav:20101023.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/paulscode/codecwav/20101
023/codecwav-20101023.pom'.
      > peer not authenticated
> Could not resolve com.paulscode:libraryjavasound:20101123.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/paulscode/libraryjavasou
nd/20101123/libraryjavasound-20101123.pom'.
      > peer not authenticated
> Could not resolve com.paulscode:librarylwjglopenal:20100824.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/paulscode/librarylwjglop
enal/20100824/librarylwjglopenal-20100824.pom'.
      > peer not authenticated
> Could not resolve com.paulscode:soundsystem:20120107.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/paulscode/soundsystem/20
120107/soundsystem-20120107.pom'.
      > peer not authenticated
> Could not resolve com.mojang:authlib:1.5.13.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/com/mojang/authlib/1.5.13/au
thlib-1.5.13.pom'.
      > peer not authenticated
> Could not resolve tv.twitch:twitch:5.16.
  Required by:
      com.riizu.letsmodreboot:LetsMod:1.7.10-1.0
   > Could not GET 'https://libraries.minecraft.net/tv/twitch/twitch/5.16/twitch
-5.16.pom'.
      > peer not authenticated

Looks like my repo is missing a few of the files, will see about getting them added in for you. Should probably have all the ones it is listing anyway.

There, everything listed in your second error is now up there. The only thing I should note, I only had authlib 1.5.16 so you will need to change to using that instead of 1.5.13

Hmm, still receiving the errors, I think its because the build script is pointing to libraries.minecraft.net

Any idea how to fix that? :slight_smile:

I can’t have flash drive, phone or even CD-R

Working for a paranoid company that thinks every dev is trying to steal their secrets