[Discontinued] CommandSigns [v1.3.1] [API 6]


Hassan with your plugin how do i make the server respond with text to the user who clicked it? i tried /msg /w /tellraw but none off these seemed to work could you explain me at how to achieve a message to the player who clicked the sign? also not /broadcast coz that would make the user send a message to the whole server :confused:


You would set the cmd to msg @p Text


so you mean just /msg @p hi? or really cmd /mgs @p hi?

Edit: solved it :slight_smile: i don’t have to do /msg but just msg @p


When right clicked by a regular player the signs don’t do a thing, As a op all the signs work as they should

No error is shown during the process


Check that you have spawn protection off in the server.properties


ok that has helped now there is the problem with commands which should be send by the console, if a default player right clicks the sign the error: you do not have the permission to use this command

althoug what i did was /commandsign addcommand weather clear which should be send by console so do people still need the permission for that command? :confused:


I believe that it only will run commands as console if @p is included in the command.

I will add a selector so you can prefix it with c: to run as console.


would be nice :stuck_out_tongue:


Can you add a price system to this plugins, I need to set up a command shop


is it already possible to make it that if a player doesnt have enought money the second command does not run?


Are you able to add more then one command to one sign?


Yes read above to find out how :stuck_out_tongue:


Does it works for 1.12.2 already ?


Hello, are you make an update for the Sponge API 7 of Sponge ?


Is an update for 1.12.2 expected in the near future?

Update CommandSign Plugin?

will you update to 1.12.2?


its been almost a month ;-;


I’m afraid the plugin appears dead; even on Github the author is not working on it.

Hopefully someone will come along and fork it and release an updated version; until they i recommend CommandBooks


Hey guys I made a new version
CommandSigns Reloaded


Permission nodes don’t seem to be working. I am unable to get signs working unless user has the " * " permission.