Error on Player join (without plugins)

today I got a new Sponge Dev built to test my plugin (it is using the new sponge api)
When I want to connect to my server, I get:

Exception in thread "User Authenticator #1" [11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: java.lang.NoClassDefFoundError: org/spongepowered/api/eventgencore/PropertySearchStrategy
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at org.spongepowered.api.util.event.factory.ClassGeneratorProvider.<init>(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at org.spongepowered.api.event.SpongeEventFactoryUtils.<clinit>(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at org.spongepowered.api.event.SpongeEventFactory.createClientConnectionEventAuth(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at$2.fireAuthEvent(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at$
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: Caused by: java.lang.ClassNotFoundException: org.spongepowered.api.eventgencore.PropertySearchStrategy
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at net.minecraft.launchwrapper.LaunchClassLoader.findClass(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at java.lang.ClassLoader.loadClass(Unknown Source)
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at java.lang.ClassLoader.loadClass(Unknown Source)
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  ... 6 more
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]: Caused by: java.lang.NullPointerException
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  at net.minecraft.launchwrapper.LaunchClassLoader.findClass(
[11:35:38] [User Authenticator #1/INFO] [STDERR]: [java.lang.Throwable$WrappedPrintStream:println:-1]:  ... 8 more

First I thought, that this error occurs, because I did a mistake in my plugin code, but when I removed all plugins (all except sponge), the same error came up in my console.

So is there a problem with my forge version, or is there a little bug in the current dev build?

There’s been a tonne of changes recently in regards to Events, breaking the server implementations. If you haven’t already, make sure you’ve updated to the very latest build. If not, this will likely be fixed soon (it’ll be affecting everyone).

1 Like

Have you tried Sponge 602?

1 Like

Thats the point. My forge server runs the latest sponge version, so I can’t understand, why my console comes up with this error.

(Not sure, if my first post contains this)
When I join / try to join the server, I get “Timed out”

Same for me. Just setup via sponge.jar -go and i get timed out too.

For reference, i’m running:

  • Vanilla 1.8.8 as client
  • SpongeForge 602 on Forge 1499, no other mods/plugins present

This commit fixes it

Now you need to wait for someone to update the SpongeCommon reference in GitHub - SpongePowered/Sponge: The SpongeAPI implementation targeting vanilla Minecraft and 3rd party platforms.

1 Like

Sponge 592 seems to work. Haven’t tried using plugins though, but i can connect…

I guess best is to wait for a Common ref bump and a new build.

ok, then… let’s wait :slight_smile:

1 Like

This should be fixed in: (the latest Sponge build).

Sorry, this was my fault.

1 Like

Hey, no problem dude, thanks :slight_smile: