Error when trying to run server


#1

So yesterday I created server through hamachi to play with friends, everything worked perfectly fine till today morning when I tried to run the server using start.bat to allocate more RAM I got this error.
https://pastebin.com/RdpRgDcN
When I run the server with the server exe it works fine.
Any solutions? It’s hard to play on mods with default RAM.
Thanks in advance.


#2

Can i see your start.bat file?


#3

@echo off
java -Xmx2048M -jar forge.jar -o true
PAUSE


#4

Try deleting the file level_sponge.dat and restarting the server.


#5

It worked, thank you very much, the only problem is, when I enter the server I get missing registries warning.
Is there anyway to prevent this kind of problems in the future?


#6

What does the warning look like? It should have a few entries of the format modname:itemname.


#7

it says:


Does it matter? Or should I ignore it?


#8

I think it should be OK to continue. Just make a backup of the world in case anything goes wrong.


#9

Okay, thank you very much for your help :slight_smile:
Best regards