getData not present, is this just unimplemented?

Almost every time I use ___.getData(___.class) it’s “absent”. Is this mostly unimplemented? And if so, is there any way for someone to find out in the future if specific data retrieval is implemented?

So far I’ve tried DisplayNameData, LoreData, SneakingData, StoneData, and HealthData. But only HealthData has actually worked.

If it is just unimplemented, I’m wondering why something as infrequently* used as HealthData would have an implementation, but not something as commonly used as DisplayNameData or LoreData.

And as a side note, is there any way for me to find out if a specific data type has been implemented? I’ve spent the past hour trying to decipher some of the SpongeCommon code to see if DisplayNameData and LoreData are implemented for items. With little success.

I’m not sure how to find out the implementation version from my dev environment, but I downloaded the latest from git yesterday (June 14), so it’s very recent.

* in my opinion.

IIRC, @gabizou is working on the Data API implementation.

At this point, it’s still safe to assume that it’s just un-implemented. @gabizou may be waiting for the Value API, because, while it won’t make many - if any - direct changes to the Data API, the implementation of it will closely coincide with it.

Ok, thanks. Is there any place where someone could find if something is implemented or not?

This might help.


Man, you are truly awesome!

:stuck_out_tongue: lol :stuck_out_tongue: