Having a Little Trouble

Well i started working on a new server and when i run to start it i get this. Any Help from anyone.

27.04 20:37:51 [Multicraft] Server stopped
27.04 20:37:51 [Multicraft] Server shut down
27.04 20:37:51 [Server] INFO /run.sh: line 31: 14940 Killed /monitor.sh “$PID” “$USER”
27.04 20:37:50 [Server] INFO Process 14939 detected
27.04 20:37:50 [Server] INFO Process 14939 dead!
27.04 20:37:50 [Server] INFO no main manifest attribute, in /jar/custom_server.jar
27.04 20:37:50 [Server] INFO /usr/bin/java $START
27.04 20:37:49 [Multicraft] Loaded config for “Mod: Custom Server”
27.04 20:37:49 [Multicraft] Starting server!
27.04 20:37:49 [Multicraft] Loading server properties
27.04 20:37:49 [Multicraft] Server stopped
27.04 20:37:49 [Multicraft] Retrying server startup
27.04 20:37:19 [Multicraft] Server stopped
27.04 20:37:19 [Multicraft] Server shut down
27.04 20:37:19 [Server] INFO /run.sh: line 31: 4372 Killed /monitor.sh “$PID” “$USER”
27.04 20:37:18 [Server] INFO Process 4371 detected
27.04 20:37:18 [Server] INFO Process 4371 dead!
27.04 20:37:18 [Server] INFO no main manifest attribute, in /jar/custom_server.jar
27.04 20:37:18 [Server] INFO /usr/bin/java $START
27.04 20:37:18 [Multicraft] Loaded config for “Mod: Custom Server”
27.04 20:37:18 [Multicraft] Starting server!
27.04 20:37:18 [Multicraft] Loading server properties
27.04 20:37:18 [Multicraft] Server stopped
27.04 20:37:18 [Multicraft] Retrying server startup
27.04 20:36:48 [Multicraft] Server stopped
27.04 20:36:48 [Multicraft] Server shut down
27.04 20:36:48 [Server] INFO /run.sh: line 31: 26381 Killed /monitor.sh “$PID” “$USER”
27.04 20:36:47 [Server] INFO Process 26380 detected
27.04 20:36:47 [Server] INFO Process 26380 dead!
27.04 20:36:47 [Server] INFO no main manifest attribute, in /jar/custom_server.jar
27.04 20:36:47 [Server] INFO /usr/bin/java $START
27.04 20:36:46 [Multicraft] Loaded config for “Mod: Custom Server”
27.04 20:36:46 [Multicraft] Starting server!
27.04 20:36:46 [Multicraft] Loading server properties
27.04 20:36:46 [Multicraft] Server stopped
27.04 20:36:46 [Multicraft] Retrying server startup
27.04 20:36:16 [Multicraft] Server stopped
27.04 20:36:16 [Multicraft] Server shut down
27.04 20:36:16 [Server] INFO /run.sh: line 31: 15815 Killed /monitor.sh “$PID” “$USER”
27.04 20:36:15 [Server] INFO Process 15814 detected
27.04 20:36:15 [Server] INFO Process 15814 dead!
27.04 20:36:15 [Server] INFO no main manifest attribute, in /jar/custom_server.jar
27.04 20:36:15 [Server] INFO /usr/bin/java $START
27.04 20:36:14 [Multicraft] Loaded config for “Mod: Custom Server”
27.04 20:36:14 [Multicraft] Starting server!
27.04 20:36:14 [Multicraft] Loading server properties

You are trying to run the sponge jar as its own server. Instead, set up a Forge server and put the Sponge jar in the mods folder :smile:

How would i exactly make a forge server any tutorials out there?
Any u would recommend?

I’m not @mbaxter, but maybe I can help. Also, I’ve never used Multicraft or MCProHosting, so I’m going in a little bit blind, but hopeful.

Here’s a guide from MCPH - key thing to keep in mind is that you need to get a forge version exactly matching that which is in the Sponge .jar filename. Somewhere around 1397 I think. Not perfectly sure.

In addition, I just noticed this would be better suited for the Sponge Support forum. Moving it there now.

After the Fix i, i ran and got a response like this

27.04 23:36:44 [Multicraft] Server stopped
27.04 23:36:44 [Multicraft] Server shut down
27.04 23:36:44 [Server] INFO /run.sh: line 31: 29109 Killed /monitor.sh “$PID” “$USER”
27.04 23:36:43 [Server] INFO Process 29108 detected
27.04 23:36:43 [Server] INFO Process 29108 dead!
27.04 23:36:43 [Server] INFO … 8 more
27.04 23:36:43 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
27.04 23:36:43 [Server] INFO at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
27.04 23:36:43 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
27.04 23:36:43 [Server] INFO at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
27.04 23:36:43 [Server] INFO at java.security.AccessController.doPrivileged(Native Method)
27.04 23:36:43 [Server] INFO at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
27.04 23:36:43 [Server] INFO at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
27.04 23:36:43 [Server] INFO Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.Level
27.04 23:36:43 [Server] INFO … 6 more
27.04 23:36:43 [Server] INFO at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
27.04 23:36:43 [Server] INFO at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
27.04 23:36:43 [Server] INFO Caused by: java.lang.NoClassDefFoundError: org/apache/logging/log4j/Level
27.04 23:36:43 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
27.04 23:36:43 [Server] INFO at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43)
27.04 23:36:43 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:606)
27.04 23:36:43 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
27.04 23:36:43 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
27.04 23:36:43 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
27.04 23:36:43 [Server] INFO A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
27.04 23:36:43 [Server] INFO /usr/bin/java $START
27.04 23:36:43 [Multicraft] Loaded config for “Mod: Custom Server”
27.04 23:36:43 [Multicraft] Starting server!
27.04 23:36:43 [Multicraft] Loading server properties

  1. Download the Forge Installer
  2. Run the installer locally (On your own machine)
  3. Upload the files the installer generated to your multicraft server instance.
  4. Setup multicraft to run the costum jar. Use the jar with “Forge” in his name.
  5. Make sure the server runs fine. It will act like a vanilla server.
  6. Shutdown the server and refresh your FTP client.
  7. You will see that a lot of folder have been made, including the “mods” folder. Upload sponge to that location.
  8. Have fun finding plugins :frowning:. (just guessing your next problem xD)

Actually exactly the same whats on MCPH. But I just added some more sponge to it :blush:. Also seeing at your error. Your are missing some libraries. Make sure you upload everything that installer generates.