Holograms - Easily create floating texts!


#82

Error occured while executing command:
org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Lorg/spongepowered/api/entity/Entity;

Sponge version = spongeforge-1.8.9-1890-4.2.0-BETA-1653


#83

As you can see in the first line of the first post in this topic, this plugin is built against api v5, not 4.2.


#84

Ok damn thank you ! No way to have a v4.0 version ?


#85

I will always use the newest version to keep up and use added features. Also that's good practice I think.


#86

Good practise is to keep up to date with the latest release

Being nice, is also making dev builds available that work with the dev builds available for Sponge.


#87

Well, I completely forgot that this is a pre release. This plugin should be back-portable. I'll do that soon. To 4.1.0


#88

Backported v1.1.2 to api v4.1.0!

One bug: Restart server to see created holograms, probably a Sponge bug, only tested with SpongeVanilla.


#89

Hello there, whenever I do /holograms create Welcome I get this error message in console > http://hastebin.com/finavacoqo And my hologram does not appear and then it says this in chat >

Error occurred while executing command 'holograms create Welcome 'org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Lorg/spongepowered/api/entity/Entity;


#90

What's the file name of the plugin jar and what sponge api version are you using?


#91

File Name > holograms-v1.1.2
Sponge API > 4.2.0-SNAPSHOT-1f5dac2


#92

4 posts above is the v1.1.2 back ported to api v4.1+. Try that one.


#93

Using that version myself and receiving the same error as above ^


#94

Can you please post the full log?


#95

This is what appears in the console when I try;

08.09 01:52:46 [Server] Server thread/INFO [io.github.hsyyid.essentialcmds]: [Kymaera] executed command holograms create Testing
08.09 01:52:46 [Server] Server thread/ERROR [Sponge]: Error occurred while executing command 'holograms create Testing' for source EntityPlayerMP['Kymaera'/963, l='purgatory', x=-912.21, y=51.50, z=-694.97]: org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Lorg/spongepowered/api/entity/Entity;
08.09 01:52:46 [Server] INFO java.lang.NoSuchMethodError: org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Lorg/spongepowered/api/entity/Entity;
08.09 01:52:46 [Server] INFO at de.randombyte.holograms.Hologram$Companion.spawn(Hologram.kt:23) ~[Hologram$Companion.class:?]
08.09 01:52:46 [Server] INFO at de.randombyte.holograms.commands.SpawnTextHologramCommand.executedWithPermission(SpawnTextHologramCommand.kt:16) ~[SpawnTextHologramCommand.class:?]
08.09 01:52:46 [Server] INFO at de.randombyte.holograms.commands.PermissionNeededCommandExecutor.executedByPlayer(PermissionNeededCommandExecutor.kt:12) ~[PermissionNeededCommandExecutor.class:?]
08.09 01:52:46 [Server] INFO at de.randombyte.holograms.commands.PlayerCommandExecutor.execute(PlayerCommandExecutor.kt:17) ~[PlayerCommandExecutor.class:?]
08.09 01:52:46 [Server] INFO at org.spongepowered.api.command.args.ChildCommandElementExecutor.execute(ChildCommandElementExecutor.java:177) ~[ChildCommandElementExecutor.class:1.8.9-1890-4.2.0-BETA-1653]
08.09 01:52:46 [Server] INFO at org.spongepowered.api.command.spec.CommandSpec.process(CommandSpec.java:331) ~[CommandSpec.class:1.8.9-1890-4.2.0-BETA-1653]
08.09 01:52:46 [Server] INFO at org.spongepowered.api.command.dispatcher.SimpleDispatcher.process(SimpleDispatcher.java:331) ~[SimpleDispatcher.class:1.8.9-1890-4.2.0-BETA-1653]
08.09 01:52:46 [Server] INFO at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:279) [SpongeCommandManager.class:1.8.9-1890-4.2.0-BETA-1653]
08.09 01:52:46 [Server] INFO at net.minecraft.command.ServerCommandManager.func_71556_a(SourceFile:80) [bd.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.network.NetHandlerPlayServer.func_147361_d(NetHandlerPlayServer.java:815) [lm.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.network.NetHandlerPlayServer.func_147354_a(NetHandlerPlayServer.java:794) [lm.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.network.play.client.C01PacketChatMessage.func_148833_a(SourceFile:37) [ie.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.network.play.client.C01PacketChatMessage.func_148833_a(SourceFile:9) [ie.class:?]
08.09 01:52:46 [Server] INFO at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:121) [PacketUtil.class:1.8.9-1890-4.2.0-BETA-1653]
08.09 01:52:46 [Server] INFO at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$0(SourceFile:39) [fh$1.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [fh$1.class:?]
08.09 01:52:46 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_66]
08.09 01:52:46 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_66]
08.09 01:52:46 [Server] INFO at net.minecraft.util.Util.func_181617_a(SourceFile:44) [g.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:660) [MinecraftServer.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:344) [ko.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:605) [MinecraftServer.class:?]
08.09 01:52:46 [Server] INFO at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:481) [MinecraftServer.class:?]
08.09 01:52:46 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66][/details]

#96

The log seems to be using the plugin for api v5 and running on v4.1.+. Are you really sure that you only have one jar file of this plugin in the mods folder? And is the jar's name really holograms-v1.1.2-for-api-v4.1.0.jar?


#97

Ah I see, I hadn't realised there were two versions of 1.1.2, my bad I should've read it more thoroughly, thank you. I had to restart the server in order to actually see the text, but besides that it works now, thank you c:


#98

Yeah, as I have written that needed restart seems to be a sponge bug.


#99

Aye, I read that-sorry I should've been more clear, I just mentioned it in the off chance that maybe this api had been updated or something, ^^;


#100

Error in spongeforge-1.10.2-1721 latest version. start and stop server automatically.

Link error code : http://pastebin.com/0Bc0uMsu


#101

Please first re-download the plugin. If it doesn't work, try another verdion of sponge, like 20 builds earlier or sponge vanilla instead if Forge.