How to give sponge vanilla server more ram?

title says it, i get the error:

[spoiler][09:44:29 WARN] [Sponge]: Found unrecognized command line option(s): [-Xmx3072MB
, -Xms3072MB, -d64, nogui][/spoiler]
my start.bat:
[spoiler]“C:\Program Files\Java\jre1.8.0_51\bin\java.exe” -jar spongevanilla-1.8.9-4.1.0-BETA-314.jar -Xmx3072MB -Xms3072MB -d64 nogui
pause [/spoiler]

"C:\Program Files\Java\jre1.8.0_51\bin\java.exe" -jar -Xmx3072MB -Xms3072MB -d64 spongevanilla-1.8.9-4.1.0-BETA-314.jar nogui pause

I think reordering the java specific options to behind the java command solves the problem. In this example, only nogui is a minecraft command line option.

i get an error: [spoiler]
C:\Users\SLICK\spongeserver>“C:\Program Files\Java\jre1.8.0_51\bin\java.exe” -ja
r -Xmx3072MB -Xms3072MB -d64 spongevanilla-1.8.9-4.1.0-BETA-314.jar nogui
Invalid maximum heap size: -Xmx3072MB
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Press any key to continue . . .

Here you go:
java -Xms3G -Xmx3G -jar spongevanilla-1.8.9-4.1.0-BETA-314.jar


nogui is not needed for Sponge vanilla

thanks! got it!

Simon gave you the answer but for future reference you just need the first letter, so G for GB or M for MB. All you needed to change was -Xmx3072MB to -Xmx3072M

1 Like