I can't install Sponge!

Hi,

I can’t install Sponge-Forge. I don’t know why!
I have done the JAR file in the mods folder and starts the server.
But the server pauses and displays error messages .

Here is a part of the report:

[15:49:09] [main/INFO] [Sponge/]: //
[15:49:09] [main/INFO] [Sponge/]: /* /
[15:49:09] [main/INFO] [Sponge/]: /
Oh dear. Something went wrong and the server had to shut down! /
[15:49:09] [main/INFO] [Sponge/]: /
/
[15:49:09] [main/INFO] [Sponge/]: /
---------------------------------------------------------------------------------------------------------------------------------------/
[15:49:09] [main/INFO] [Sponge/]: /
/
[15:49:09] [main/INFO] [Sponge/]: /
A critical error was encountered while blending Sponge with Forge! /
[15:49:09] [main/INFO] [Sponge/]: /
/
[15:49:09] [main/INFO] [Sponge/]: /
Possible causes are: /
[15:49:09] [main/INFO] [Sponge/]: /
/
[15:49:09] [main/INFO] [Sponge/]: /
* An incompatible Forge “core mod” is present. Try removing other mods to /
[15:49:09] [main/INFO] [Sponge/]: /
see if the problem goes away. /
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
* You are using the wrong version of Minecraft Forge. You must use the /
[15:49:10] [main/INFO] [Sponge/]: /
correct version of Forge when running Sponge, this version is for /
[15:49:10] [main/INFO] [Sponge/]: /
11.15.1.1890-1.8.9 (you are running 11.15.1.1722) /
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
* An error exists in Sponge itself. Ensure you are running the latest version /
[15:49:10] [main/INFO] [Sponge/]: /
of Sponge. /
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
* Gremlins are invading your computer. Did you feed a Mogwai after midnight? /
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
---------------------------------------------------------------------------------------------------------------------------------------/
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
Technical details: /
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [Sponge/]: /
Failed on class : net.minecraftforge.event.ForgeEventFactory /
[15:49:10] [main/INFO] [Sponge/]: /
During phase : DEFAULT /
[15:49:10] [main/INFO] [Sponge/]: /
Mixin : forge.event.MixinForgeEventFactory /
[15:49:10] [main/INFO] [Sponge/]: /
Config : mixins.forge.core.json /
[15:49:10] [main/INFO] [Sponge/]: /
Error Type : org.spongepowered.asm.mixin.transformer.InvalidMixinException /
[15:49:10] [main/INFO] [Sponge/]: /
Caused by : Unknown /
[15:49:10] [main/INFO] [Sponge/]: /
Message : Overwrite target “onPlayerInteract” was not located in target class net/minecraftforge/event/ForgeEventFactory /
[15:49:10] [main/INFO] [Sponge/]: /
*/
[15:49:10] [main/INFO] [Sponge/]: /
/
[15:49:10] [main/INFO] [FML/]: Java has been asked to exit (code 1) by net.minecraftforge.fml.common.FMLCommonHandler.exitJava(FMLCommonHandler.java:648).
[15:49:10] [main/INFO] [FML/]: This is an abortive exit and could cause world corruption or other things
[15:49:10] [main/INFO] [FML/]: If this was an unexpected exit, use -Dfml.debugExit=true as a JVM argument to find out where it was called

Please help me!!!
Thank you!!!

You are using the wrong version of Minecraft Forge.

@Seema What version of Forge must I use??

It’s in the log by the way.

Whenever you download sponge, the corresponding version of forge is included in the file name.

I recommend reading https://docs.spongepowered.org/master/en/server/getting-started/implementations/spongeforge.html

1 Like

Thank you for help!!

1 Like

yes 11.15.1.1890-1.8.9 or higher

Thank you for help!! @Seema

1 Like