MineReset ⛏ Refill mines with defined blocks and percentages


#21

I don't think that is something that I can do as it woudl be dependant on where the mine is in height and biome the percentages can be different. It would also be different and because naturally generating ores generate in veins and not randomly as with my code. Sorry :frowning:


#22

The mine is set on reset and wont actually reset, anyhelp?


#23

Version? If you do "/mine fill [mine]" does the mine fill correctly? Could you pastebin your config and any console errors on attempted mine reset


#24

nevermind i was an idiot and was using an outdated version :joy: fixed it now and plugin works beautifully


#25

Nice to hear. Glad its all working for you :smiley:


#26

never saw nothing so hard to setup xD


#27

Originally it was easy but as I added more stuff things started getting more complicated XD

Did you manage your way though tho ok?


#28

Hi! The plugin looks great! i tried following the quick start guide by simple creating a mine with a 20% chance of coal, however, when i do ./mine fill Test it gives me a error saying "error executing command: null" is there any fixes?


#29

What version are you using? Have you set up the spawn? If 1.0.5 and yes to the spawn can you please paste bin your config and send me the console error when you try and fill the mine. With all that i should be able to tell you the issue


#30

So i tried creating another mine and the "Mineticks task" seems to not be working, i get http://pastebin.com/7VMFm1hz
Flooding my console, and flooding chat too. I set up a default spawn and am using sponge 4.2.0 with the latest version of MineReset (1.0.5) i've tried downgrading to 1.0.4, same problem.


#31

As mentioned in discord (in case you haven't seen it) could I please have a paste bin of your config. I know it works when setup correctly as I use it personally however I think there may be an issue either with your setup or the setup commands not successfully doing a task. I will read your config and then they and find what exact line is the issue :smiley:


#32

@JamieS1211 i have this error when trying to fill a mine, im following the quick guide tutorial, did everything fine i guess, error in console http://pastebin.com/v6XQpQRV
Error on minecraft http://prntscr.com/celjuv
Plugin config: http://pastebin.com/PXJH6G6z

Im using lattest version of the plugin
Sponge forge
Minecraft: 1.10.2
SpongeAPI: 5.0.0-SNAPSHOT-d41be56
SpongeForge: 1.10.2-2044-5.0.0-BETA-1660
Minecraft Forge: 12.18.1.2050


#33

I believe we sorted this on discord and the issue was a result of an API change sorted by the new released.


#34

Hey @JamieS1211 Will you be updating this mod to a 6.0 variant? Would be much appreciated!

Thanks,
Riddle


#35

No need, this currently functions correctly on API 6.0.0
:slight_smile:


#36

I have two mines in my world.
One of them works fine and the other fills with all stone on reset, why is it filling with stone?

:slight_smile:


#37

Does this plugin supporting 1.11.2?


#38

What happens when a player mines into a mountain or underground and builds a house in that area where the ores are set to regenerate ?


#39

I have a suggestion for this plugin. Is it possible to use a tool to mark several areas and the plugin only refill these areas?


#40

That is what this plugin does however the cuboid regions are defined not by a tool but by typing in coordinates using a command.