Mirage - The best solution against xray users


#21

I answered on github. No need to ask for help here. I’m already notified when someone open an issue on github. :wink:


#22

A new version has been released for Mirage, it is available for download here.


  • Require SpongeAPI 7.1.0 and so SpongeForge/Vanilla 7.1.2 or +. (since 1.3.5)
  • Fix bStats
  • Improve update checking (again)

#23

It didn’t work with spongevanilla-1.12.2-7.1.0-BETA-64. Upgrading to spongevanilla-1.12.2-7.1.4 fixed that.


#24

I forgot to mention that the new version require SpongeAPI 7.1.0 and so SpongeForge/Vanilla 7.1.2 or +.
It should now be fixed. :wink:


#25

No problem, you pushed me to update the whole server :slight_smile:


#26

Could this crash be related to the plugin? Don’t wanna open a ticket cuz I’m not sure.


#27

You might have forgotten to provide related report :sweat_smile:


#28

oops lmfao

https://pastebin.com/K566DDZd


#29

This crash was caused by version 1.3.3, it has been fixed, you should use the latest version of Mirage (1.3.6 currently). :slight_smile:


#30

I see. Thank you :smiley:


#31

Hey, passive mobs stop moving around as soon as I add Mirage to my SpongeForge server.
I’m on the latest SpongeForge version, any idea on how I could fix that ?


#32

To help you I need your logs (use a service such as pastebin to host them) and either a Timings report or Spark report. :slight_smile:


#33

Here are some logs from my SpongeForge server :
https://pastebin.com/eggsiqW2

I’ll try to get you a Timings/Spark report asap.

P.S : Do you have a Discord account ? Would be easier to talk through it.

Edit : here’s the Timings report :
https://timings.aikar.co/?id=bb78faedc2a440acaf58331f99a5923c


#34

Sorry for the delay, I’m very busy these days. :sweat_smile: An issue has been opened, I’m investigating on it. I invite you to follow it, it’s also the best place if you want to talk about it.


#35

A new version has been released for Mirage, it is available for download here.


  • Require SpongeAPI 7.1.0 and so SpongeForge/Vanilla 7.1.2 or +. (since 1.3.5)
  • Fix mobs not moving and grass spreading abnormally
  • Minor optimizations

#36

A new version has been released for Mirage, it is available for download here.


  • Require SpongeAPI 7.1.0 and so SpongeForge/Vanilla 7.1.2 or +. (since 1.3.5)
  • Fix incompatibility with Chisel

#37

Hey could you help me figure out what I’m doing wrong. I have it setup and working but sometimes blocks dont disappear. They’ll look like https://i.imgur.com/miQacgN.png. There was a player mining there and then they just stay like that until he breaks them (it was happening before I tp’d to him). This is my world conf file. https://gist.github.com/Trnrr/2d2b80a1fa2dac7806659f7b0284b0ad I just changed the NaturalRadius to 2 and the PlayerRadius to 4 to test to see if that fixes it. It was at 1 and 2


#38

Sorry I cant edit my above post. I forgot to mention that the server was not lagging to have tps drops when it happens. Tps and tps average were at 20


#39

It’s normal for the ores next to a block of air to be visible if you are close enough. Otherwise, normal players would not be able to see any ore. Are these ores still visible if you go backward enough ?


#40

Thanks for the fast response. I’m not sure if I’m reading your message wrong or I didnt explain right. The ore blocks in the screenshot I posted are all fake ores. When the player mines them they disappear and turn to stone. I didn’t test the walk backward thing. But I will keep that in mind if that happens again.