Nucleus: The Ultimate Essentials Plugin (MC 1.10.2, 1.11.2, 1.12.2)


#762

We’ve tried that as well. Same issues occured. Figured it may be Forge so we tried different versions. Forge 2107 causes it to happen every 15 or so minutes while the others take about 30 minutes. Running 2097 with 30m interval disconnections. Just occurred again after deleting our chron tasks for /list
http://pastebin.com/ra8ezxST
I will turn on debugging so we can see

EDIT: I deleted chron command for list but it appears Multicraft still runs it to display playerlist and there isn’t a way around it for those using Multicraft


#763

Obtained this error right after /list with debugging on and mass disconnect
http://pastebin.com/A3fjpjmj

http://pastebin.com/UJif0d0U


#764

Spongevanilla 1.10.2 API5 versions, Nucleus 0.13.10-S5 (though this also happened in at least the 0.11 version…)

When players do /suicide or I /kill them, they respawn with their inventory intact.
If I remove nucleus, /kill drops their inventory on death and they respawn empty as expected.

I can not see any setting or permission in the configs that controls this, and I don’t have any gamerules set.
Is nucleus indeed keeping their inventory on suicide/kill, and is there a setting I’m overlooking?


#765

Hello, A moderator I have was using the PowerTool feature and didn’t realize that when he deleted the ingame tool (by dropping it in the delete spot in his inventory) that it didn’t clear the powertool function and earlier today I was using a hoe and it pasted from the clipboard. So my question is, is it possible to clear all the powertools, or is there a file that holds all the info for powertools that I can remove to manually remove them? Otherwise I have to go through each item (there are additional tools added by the Mod were running) and run ‘/powertool delete’ since he has used many different tools over the last week.


#766

I am running into issues with the config for editing chat for nucleus. Could I get some guidance? I was following the webpage for nucleus’s chat but when I editted, my server crashed and nucleus stopped working.


#767

@Michael_Ware It could be that Multicraft is doing something with the list command and disconnecting/connecting players - it might not recognise the format. Might have to try to do something funny with the /list command to support Multicraft.

Broken pipe means that the network connection has just been broken - that is, essentially a forced disconnection that no-one was told about. Connection reset by peer is a similar story.

@TheBoomer Sponge issue - had a PR open for four weeks to fix it now. https://github.com/SpongePowered/SpongeCommon/pull/969

@Dank_Sinatra Yeah, powertools are per item type, not per item, though there is an issue open to consider that. However, to answer your question, the user’s json file, but you’ll need to stop your server to alter it (or boot him and use /nucleus clearcache after).

@TacticalTickler Sure, if you explain what you’re trying to do, I’m sure we can help.


#768

If you translated the messages, try to save file in utf-8.


#769

I am trying to implement the group template into the default chat module and whenever I do so nucleus breaks. Here is my chat module that breaks nucleus:
http://pastebin.com/aYfupVq6


#770

Will there be a bug fix update soon? This pastebin is the error for /warp http://pastebin.com/2WACEB1G


#771

Version 0.14 is now available for Minecraft 1.8.9 and 1.10.2

This version supports Sponge API 4.1 and 5 (1.8.9 and 1.10.2).

IF YOU ARE RUNNING MC 1.10.2 you MUST be running SpongeForge for API 5.0, 5.1, or current builds from API 6.

This release has the follwing new features:

  • Enhanced blacklist
  • Blacklist now supports per item support of environment (placing/breaking blocks), interaction and use blocking.
  • /blacklist add and /blacklist remove have been replaced by /blacklist set [-t <action to block>] <item> <true|false>
  • Blacklist data moved to items.conf from general.json, should prevent item ID changes breaking general.json.
  • Blacklist information is migrated automatically.
  • Added permission nucleus.connectionmessages.disable prevents join/leave messages from appearing.
  • Added /kits, /worlds, /warps commands as aliases for /kit list, /world list and /warp list
  • Added ability to add warp categories using /warp setcategory for categorisation in /warp list

For those of you using Multicraft, set playerinfo.list.multicraft-compatibility in main.conf to true. This should hopfeully resolve issues when /list is run from the console, Nucleus changes the output so Multicraft could be getting confused. This switch will revert /list to use /minecraft:list when executed from the console.

Download from GitHub Releases: https://github.com/NucleusPowered/Nucleus/releases/tag/0.14.0
Command documentation is already up to date: http://nucleuspowered.org/docs/commands2.html


#772

hi, can i give default players the command to do /bal?


#773

Nucleus does not handle economy at the present time. Check with the economy plugin that you use.


#774

ok,thanks, i’ll try that now. Can you recommend one possibly?


#775

No, I don’t have a particular favourite. Have a search on the forums, see what people like.


#776

ok. I understand. Thanks for the quick reply’s and your plugin is gr8


#777

good work. plugins.


#778

When attempting to run invsee on this latest nuc build i get this console error:

07.11 09:08:07 [Server] Server thread/WARN [mixin]:
Method overwrite conflict for getSlotProvider in
mixins.common.core.json:item.inventory.TraitInventoryAdapter, previously
written by
org.spongepowered.common.mixin.core.inventory.MixinInventoryLargeChest.
Skipping method.

The inventory of the payer flashes on my screen for about 0.3 seconds and disapears. /Enderchest works fine for me, am I doing something wrong?

I’m running the latest version of spongeforge and the corresponding forge version.


#779

I’ve been told that if you are close to the player, it works fine, which makes me thing that it’s treating it like a chest where you have to be close to the location of the chest for it to actually work. Try standing near the player, use /invsee, then get them to walk away from you. I assume that based on the reports I’ve got, it should close.

It’s been reported to me before, but I’ve not had the time to investigate

I don’t know if this is intended behaviour, my feeling is that by using the method I’ve used, it possibly isn’t, and so it might need looking at on the Sponge side - @Aaron1011 (you’re the first person that comes to mind, sorry!), do you know if this is something you feel is a Sponge issue?

Otherwise, I think I might have another idea on how to solve this, but it might take me a little time to get the specifics right.


#780

Bumb

Still having issues with the chat


#782

Thanks, I got it fixed using this information