🔑 PermissionsEx v2.0 [API 5]

If I wanted to configure a config file (unsure if supported yet) where would I put it? /mods maybe? If i can’t use a config file yet then what would the command be to set a new group (ex. Owner) and to give it the “*” perm node?

I use multicraft by the way so all files edited locally then uploaded to server through FileZilla.

I would really like to get started on AdminEX, but I’d love to work closely with you on it, as you have a better understanding than anyone the best way to go about designing the web-side of it.

If you could provide me a UML or something for me, I’d be happy to create the web-panel for it.

What is the command to create a new Group and what is the command to give permissions.

sorry for my bad english I come from Germany :confused:

Okaaaayy everytime i use /pex i get this:

PermissionsEx v2.0-SNAPSHOT
/pex [–context|–contexts|-c] [-transient] [reload|debug|subject permission|permission-default|options|info|parents]

and every time i try to do something useful like /pex group I get this:

Too many arguments!
Usage: /pex [–context|–contexts|-c] [-transient] [reload|debug|subject permission|permission-default|options|info|parents]

Go ahead and post your issue on the projects Issues page. Just easier to keep track of things there. :smile:

@xSloth @DomiMC @Hergarian Again, commands have brief documentation at Commands · Issue #1945 · PEXPlugins/PermissionsEx · GitHub
(and yeah, usage messages are a bit off at the moment unfortunately, that’s a work item)

The new PEX does not support any web interfaces currently – it has a new file format and a new API.

@KieronWiltshire What I’m hoping to do is to have a JSON RPC API for interacting with PEX’s data, or do a web app in java so we can take advantage of shared code. However, that’s a bit down the road

@zml understandable, the JSON RPC API would the best method as it has much more agnosticism in regards to where it can be used.

could we possibly talk about this on instant or private message? (IRC preferably)
I’d love to get started on this as soon as possible.

The documentation must be changing in an extreme way. The example file & permissions.json formating do not resemble each other. Documentation could use quite a bit of work. Eagerly awaiting a workable version of this plugin, or if already workign basic instructions on how to add user, group, etc. permissions.

1 Like

yeah, the plugin is heavily in development, so a lot of the things that are there are changing frequently as I try different things to figure out what works best. And yes, documentation is generally the last part that comes in

Excellent! Me much likey! PEX forever!

1 Like

Been playing around a bit here. Trying to just straight up rebuild my perms instead of porting from the .yml in bukkit. I’ve tried every command I could think of directly in the console with no luck. I’ve also read issue 1945 on github. The output is always “Too many arguments!” with no error outputs in the log.

mineos 0.6.0
Debian GNU/Linux 7.8 wheezy

Anyone have thoughts on this issue?

The command usage information is a bit broken right now – take a look at Commands · Issue #1945 · PEXPlugins/PermissionsEx · GitHub for brief information on what commands are available.

Also, if the folder config/permissionsex does not exist and a bukkit plugins/ folder exists in the same directory as the forge jar, configuration data will be automatically converted, including your permissions.yml.

Thanks for the quick reply! :slight_smile:

Is there a specific name that the [plugins/folder] needs to be? Doesn’t seem to want to pull the old data out of the .yml, it just rebuilds a fresh permissions.json and permissionsex.conf

It should be the same folder structure as from Bukkit. Just remember that nothing will be converted if a config/permissionsex folder exists already, but if that folder doesn’t, then file conversion should work. I’ll take a look at that code, but it worked the last time I tested it.

Ok when I’m back on my machine I will try what you suggested. My guess is maybe the capitalization of the pex folders from bukkit is causing the issue, I will continue to experiment and post my results.

Could you provide an example of how we would create a group please? And could you expand on how /pex [–transient] <user|group|etc> --context = works please? The information at Commands · Issue #1945 · PEXPlugins/PermissionsEx · GitHub isn’t really helping me :frowning:

Commands · Issue #1945 · PEXPlugins/PermissionsEx · GitHub has been updated to provide additional information about the commands. Let me know if that helps

1 Like

@zml is there a list of sponge permissions anywhere?

Sponge-specific permissions · Issue #166 · SpongePowered/SpongeDocs · GitHub is a temporary list until somebody properly updates the docs.

That list says it is incomplete (and it was marked WIP). Are there any pointers to the missing bits?
We’ll try to get a Docs page put together for it soon.

[POST EDIT]: The SpongeDocs Commands page is now updated with the new Sponge permissions.

1 Like