Pixelmon server crashing and stopping on start due to not being able to read level_sponge.dat

Hello my Pixelmon server has been working fine so far but recently I added sponge forge to be able to assign commands to players using LuckyPerms and it was working fine for 2 or 3 days but now when my server boots it runs then says “Unable to load level data from world [world] for file [level_sponge.dat]!” and “Encountered an unexpected exception java.lang.RuntimeException: Exception trying to load level_sponge.dat, file corruption maybe?” and force stops the server, im wondering if I can just delete the level_sponge.dat and the server will run or cause issues?

Here is the crash report:

---- Minecraft Crash Report ----

WARNING: coremods are present:
SpongeCoremod (spongeforge-1.12.2-2838-7.3.0.jar)
Contact their authors BEFORE contacting forge

// Don’t be sad, have a hug! <3

Time: 15/02/21 10:03 AM
Description: Exception in server tick loop

java.lang.RuntimeException: Exception trying to load level_sponge.dat, file corruption maybe?
at net.minecraft.world.storage.SaveHandler.redirect$bbd000$forgeImpl$hookToUpdateSpongeLoadData(SaveHandler.java:1609)
at net.minecraft.world.storage.SaveHandler.func_75757_d(SaveHandler.java:132)
at org.spongepowered.common.world.WorldManager.loadAllWorlds(WorldManager.java:771)
at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:4390)
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:270)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:486)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Unable to load sponge data for world [world]
at net.minecraft.world.storage.SaveHandler.bridge$loadSpongeDatData(SaveHandler.java:1328)
at net.minecraft.world.storage.SaveHandler.redirect$bbd000$forgeImpl$hookToUpdateSpongeLoadData(SaveHandler.java:1607)
… 6 more

A detailed walkthrough of the error, its code path and all known details is as follows:

– Head –
Thread: Server thread
at net.minecraft.world.storage.SaveHandler.redirect$bbd000$forgeImpl$hookToUpdateSpongeLoadData(SaveHandler.java:1609)
at net.minecraft.world.storage.SaveHandler.func_75757_d(SaveHandler.java:132)

– Sponge PhaseTracker –
Phase Stack: [Empty stack]
at net.minecraft.server.MinecraftServer.handler$zjg000$onCrashReport(MinecraftServer.java:4687)
at net.minecraft.server.MinecraftServer.func_71230_b(MinecraftServer.java:889)
at net.minecraft.server.dedicated.DedicatedServer.func_71230_b(DedicatedServer.java:371)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:558)
at java.lang.Thread.run(Unknown Source)

– System Details –
Minecraft Version: 1.12.2
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_261, Oracle Corporation
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 5658170816 bytes (5396 MB) / 8378122240 bytes (7990 MB) up to 8378122240 bytes (7990 MB)
JVM Flags: 2 total; -Xmx8192M -Xms8192M
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP 9.42 Powered by Forge 10 mods loaded, 10 mods active
States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored


| State  | ID          | Version           | Source                                  | Signature                                |
|:------ |:----------- |:----------------- |:--------------------------------------- |:---------------------------------------- |
| LCHIJA | minecraft   | 1.12.2            | minecraft.jar                           | None                                     |
| LCHIJA | mcp         | 9.42              | minecraft.jar                           | None                                     |
| LCHIJA | FML         |         | server.jar                              | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| LCHIJA | forge       |      | server.jar                              | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| LCHIJA | spongeapi   | 7.3-7127e0882     | spongeforge-1.12.2-2838-7.3.0.jar       | None                                     |
| LCHIJA | sponge      | 1.12.2-7.3.0      | spongeforge-1.12.2-2838-7.3.0.jar       | None                                     |
| LCHIJA | spongeforge | 1.12.2-2838-7.3.0 | spongeforge-1.12.2-2838-7.3.0.jar       | None                                     |
| LCHIJA | pixelmon    | 8.1.2             | Pixelmon-1.12.2-8.1.2-universal.jar     | None                                     |
| LCHIJA | pixelextras | 2.5.11            | PixelExtras-1.12.2-2.5.11-universal.jar | None                                     |


| State  | ID        | Version | Source                      | Signature |
|:------ |:--------- |:------- |:--------------------------- |:--------- |
| LCHIJA | luckperms | 5.2.76  | LuckPerms-Sponge-5.2.76.jar | None      |

Loaded coremods (and transformers): 

SpongeCoremod (spongeforge-1.12.2-2838-7.3.0.jar)
Profiler Position: N/A (disabled)
Player Count: 0 / 20; []
Is Modded: Definitely; Server brand changed to ‘fml,forge,sponge’
Type: Dedicated Server (map_server.txt)

Ideally you should restore the file from a backup instead of deleting it completely.

If you do not have backups (which you should fix), Then yes - deleting the file will probably be ok.

This usually happens when a server crashes or is shut down abruptly or similar - try to make sure the server stops correctly.

I tried using an automatic backup script when I had a vanilla server with the essentials plugin that would back up the server every day and delete server files older than a week however when I got it finally working it was only saving the plugins folder.

Is there a plugin you would recommend for this kind of backing up?, also thanks for the help

No, because I don’t like the way most plugins back up. I would recommend using an actual server backup solution instead.

As in a server host backup or just copying and pasting the server folder?

The server I run is ran off my pc and not a server hosting site as its just for me and my real life friends so I’m not sure if i could implement that or not in my case

Um I have deleted the sponge file and the same error is still occuring

Check that the error isn’t now referring a different world. Often times if one world file get a corrupt the files for the other dimensions will be as well

Thanks! there was also a file called level_sponge.dat in the DIM- 1 and DIM folder as well that was corrupted and now everything works fine and there’s no corruption seen in the world so far. Thanks for your time!