Problem with sponge on my server

Hello everybody,

i’m belgian and i hope that i won’t make a lot of mistake. Thank you for your understand…

Forge version: 1.8-11.14.1.1397
Sponge: 1.8-1371-2.1DEV433

I have a problem when i put sponge on my server (into the mods folder)
When i have a mod in it: it’s ok but when it s sponge, i suddenly cannot make anything with the RCon or something else. The error message when i try to make any commands in the rCon:

Error executing: help (net.minecraft.network.rcon.RConConsoleSource cannot be cast to org.spongepowered.api.util.command.CommandSource)

I don t uderstand what i need to do. Can you help me please

Are you using any plugins?

If so, It might be one of those.

Otherwise, Recon might not be implemented yet.

It looks like an error caused by Sponge itself.

Go to this page and open a new issue: https://github.com/SpongePowered/Sponge/issues/new

@WetSponge : I don t use any plugins yet. I only tried to install sponge
@boformer : ok, i’ll do it direclty

If someone has got an idea to help me, I would be happy :slight_smile:

put ur forge at 1371 --> solved.

Forge and Sponge will must be " same version "

" same version "…

" same version " … read spongedocs first of all D: …

@Shiva I tried with the forge 1371 but it was the same result

@Shiva If you don’t know what the issue is, don’t reply.

Before this thread goes farther I’ll note that the issue is known and tracked via this github issue.

3 Likes

@Daemon Yeah, it s me who put this issue on github thanks to boformer who told me to do that

2 Likes