Problem with SpongeForge and Server console


#1

After setting up SpongeForge in my Forge server’s files the console didn’t show up. At first, I figured it just crashed, but no. My server is up and I can connect to it, but, as I said, there’s no console.

Is this a bug, or a feature? If a feature, is there a way to open up the console? I can see it in task manager as well, so I’m a little confused, haha. Maybe I’m just being dumb and I missed something.

EDIT: I’ve never run a server with plugins/never used plugins. Would I need the API to run anything, or is the API included in SpongeForge? Also, if there’s confusion I mean the Java console, not the run batch file.


#2

SpongeForge, from what I can tell, disables the Forge console. There’s probably a config or a way around it, but I personally get a console from running my batch file (which I prefer). Are you getting neither console? I’m assuming you’re not using a panel because they usually handle that.


#3

The GUI is disabled for performance reasons. You need to use the command line

See:
https://docs.spongepowered.org/stable/en/server/getting-started/launch-script.html#running-a-launch-script

The default Minecraft server GUI console is disabled by Sponge, because it is very processor-intensive.


#4

No, I wouldn’t think I’d have a problem with the batch console. I assumed the launch batch file works, which is good, but I just prefer the java console, haha.

If SpongeForge does disable console, would you know how to stop it, or at least where the right config file is?

Thank you for the answer :slight_smile:


#5

Does it tell me how to enable it, or might you know? I can’t seem to find it on the site, but I might not be looking hard enough lol.

I’d think my processor is good enough to run the GUI, being a newer CPU.

Thanks for the answer :slight_smile:


#6

There is no way to enable it with sponge running. The command line console works fine for administration purposes.


#7

That’s unfortunate. Oh well, it’ll do haha.

Thanks for your help, I appreciate it. Have a good one :slight_smile: