Server begin Crash


#1

Hello,
My server crashes when starting directly why that is due to the Sponge Mod have tried all versions.
https://pastebin.com/qXzMC0Rj


#2

You have a version mismatch. You’re using spongeforge-1.12.2-2705-7.1.0-BETA-3171 but running Forge Mod Loader version 14.23.2.2641. You need to use the Forge version mentioned in the SpongeForge filename - ie. 2705 (or later).


#3

Thank you first I have updated forge but now he stays at the line and does not start

https://pastebin.com/zAjXR97a


#4

[14:31:47] [Server thread/INFO] [Sponge]: Creating injector in stage ‘PRODUCTION’
[14:32:05] [Server thread/WARN] [Sponge]: sponge: It is no longer required to include the plugin id when specifying a Key id through Key.Builder#id. This is deprecated and may be removed later. The plugin id will be retrieved from the current PluginContainer in the cause stack.


#5

That has no significance. It’s just a deprecation warning.
Try running a clean setup of the server pack without SpongeForge first, then again with it in. It may be that a coremod is conflicting with Sponge, or there might be something else about the setup that makes it seize up. Give it some time if the WGen mods are heavy handed, too.