Server connection issues - looking for workaround with Forge

I understand that this is not really a Sponge issue, but I really don’t know where else to look. I can’t seem to get any solutions from anyone else, and was wondering if you guys might take a stab at it. Sponge seems to have it’s shit together!

The issue is essentially this: Faulty netty-4.1.9
And here’s my post on Forge Support with attached logs: 1.12.2 Server becomes unreachable

In the mojang bugs thread, it seems that a simple workaround to use a new netty version works well for vanilla and spigot, but for forge the same workaround cannot be used. Does anyone have any idea what can be done to get around this?

1 Like

So you are running a forge server? Do you have spongeforge in mods or just sponge? Also, is it a compatible sponge version with the forge version you are using? Please provide a list of all the plugins and or mods you have installed on your server.

EDIT: Also add what java version you are rockin

Here’s what I’m using:




The issue is unaffected by Sponge. The same thing was happening before I migrated to Sponge. Everything works perfectly fine otherwise. I run a server with a bunch of friends, I just end up having to restart the server about every 4 hours if people are trying to join due to what is essentially this:

WARNING: Failed to re-register a Channel to the new Selector.
java.lang.ClassCastException: cannot be cast to java.nio.channels.spi.AbstractSelector
        at java.nio.channels.spi.AbstractSelectableChannel.register(Unknown Source)
        at io.netty.util.concurrent.SingleThreadEventExecutor$

        at Source)

after which no players can connect to the server (but most players already on the server can keep playing!).

To get further info, I’m currently running a control server with the same version of Sponge and Forge, but without any mods or plugins installed. I essentially just have to wait a while to see if the error occurs. I have a pretty good feeling that it’s as stated in the mojang bugs thread, a vanilla issue with 1.12.2 that only affects certain OS versions/kernels/I don’t really understand exactly.

Are you running this at home? If so, it may be because you have a dynamic IP as opposed to a static IP.
My two suggestions are either use NoIP or set up a staic IP.

I prefer the NoIP, due to you being able to name it whatever you want (i.e. if your ip is you can make it like All you have to do is confirm your dns every 30 days. Also download the software to the host pc so it can check your IP and update it.

I set up a static IP a looong time ago for hosting all sorts of various games, and that hasn’t changed. I don’t even think I could host a server period if I wasn’t port forwarded to a static IP.

EDIT: I ran a completely vanilla server for several hours until eventually getting the same error and then was unable to connect. This is a bug with 1.12 on particular setups.