Server crashing on start up

Our modded server is crashing on start up, we haven’t changed anything and randomly got this crash log when we were turning the server on. From what I’ve tried to find it might need us to rollback a bit, but if I’m missing something and there’s a more viable solution let me know!

Thanks!
https://pastebin.com/A72EUjNz

The relevant bit is:
Attempt failed when reading Sponge level data for [Ezarion] from file [level_sponge.dat]!
There should be a backup of the file present, called level_sponge.dat_old; you can rename that and see how things go as a first attempt. Somehow it got corrupted, possibly by an abrupt shutdown or crash. It might not be the only one damaged, as each world has such a file.
Failing that you can try the version from an older backup, or even delete it and let it regenerate (some Sponge specific data will be lost, but the world should load).

Hello,

We tried the solution you gave us but we still seem to be unable to start up the server still

https://pastebin.com/LPyuMxTN
^This is the newest crash log if it can give an insight on what’s wrong.

Thanks!

I did warn you that each world has such a file. This time it’s DIM-1. They may all be corrupted.
java.lang.RuntimeException: Attempt failed when reading Sponge level data for [DIM-1] from file [level_sponge.dat]!.

Hiya,

The solution you mention did work at first, but after one startup we’ve run into the same issue again.
https://pastebin.com/x1J6tJfS
This is the latest crash
Could there be something in game that’s causing this?

Thanks

If it started and shut down normally, then something else is corrupting the sponge_level.dat file. Possibly a broken mod or plugin. I’m afraid I have no clue what.