Services that are blocked in school

I have a problem with internet blockage at school. I tried following things to get trough:

Tunnels:

  • ptpp tunnel : port status in school: filtered : port status at home: open
  • http proxy: port status in school: filtered : port status at home: open
  • ssh tunnel: strangely enough ssh works, only the moment I do tunnel it blocks.

Services that are blocked:

  • Any unknow protocol. (I tried to make my own “proxy” protocol with python. But port status also was filtered ;-:wink:
  • telnet/irc (I need this ;-:wink:
  • skype

Are their any methods I have missed? VPN worked for 2 years, but its gone now … .

Ask teachers if wifi could be allowed during recess?

Well it is allowed. So thats not a problem ;). Only that firewall is killing me…

Nvm I was doing stupid. Forgot to allow it in my ssh server

This did the trick :smile:.

#!/bin/bash
autossh -oStrictHostKeyChecking=no -L 8000:localhost:8000 thomas15v.net
autossh -oStrictHostKeyChecking=no -L 25566:s1.thefantasycraft.com:25565 thomas15v.net

I have this issue to, I’ll have to see if ssh works over 8080 (for some weird reason unblocked) I can access skype but only through 443 and 80 and only chat (irc don’t work either).

My school uses this for thier blocking, any help if appreciated (I have a VPS I can use).

1 Like

My school used the same, it’d be cool if we could find a way around it.

Hmm if you can SSH you can make tunnels. But ofc you need to have the luck to have that unblocked.

If you are on school try this command:

nmap thomas15v.net -p 1723

It will tell if you can connect to a VPN (port open). And if that is the case, simply install a pptp on your server (or msg me for the login and pwd xD) and bam unblocked internet :smile:.

nmap isn’t a command on windows

Do your homework, so you have more time to screw around online when you get home.

7 Likes

At my school, everything was very open at first, but some kids started playing Minecraft (yeah, MC, as it doesn’t need to be installed nor does it need admin privileges to be run). So they blocked traffic on every port except 80. For two weeks, Google didn’t work because it was redirecting everyone to HTTPS, which uses port 443 which was blocked. Then they unblocked it. So, right now, the only two ports we can use are port 80 and 443. However, I don’t believe the firewall spoofs non-HTTP traffic. Some websites are blocked, logically. There is, however, an easy way of circumventing this problem. There’s a wireless network that covers the entire school, to which we have access, that doesn’t have any ports blocked. So, when I want to establish an RDP (or FTP, or whatever) connection to home (or any other host), I just use an USB cable to connect my Smartphone to the PC and share the wireless internet via USB. I must also disconect the Ethernet cable from the PC. Done.

4 Likes

Try to download nmap.exe or use an usb: Zenmap Portable Development Test 1 | PortableApps.com. :smile:
you could also try: telnet thomas15v.net 1723 could give you an idea if the port is up or not.

nmap.org is blocked by the filter, and the portableapps site was blocked cause I found it and have been using it to run stuff on here. Also it appears that telnet isn’t a windows command.

Isn’t it fun when you’re the sole reason they make their security policies stricter? :smiley:

4 Likes

What about that time I found a way to bump myself up to an admin from a student on my schools site, just by visiting a url? or the time I found out they were using an old drupal version and hacked my way in, just to make them update the site version. (mind you my school puts their grades on that site). It’s amazing I’m not expelled yet (or suspended). Aren’t I something special? BTW It is fun, I keep finding out their passwords two on top of everything else.

1 Like