Severely delayed server


#1

Hello, I need help.
I have two servers and a bungeecord
There is a login server
There is an industrialcraft + Galacticraft server
The system includes:
Cpu: Intel ® Xeon ® E5-26900 @2.90GHz
Memory: 10GB
Galacticraft server has serious latency
I set up 5GB of memory for the Galacticraft server
I observed that the average CPU was about 33%.
The Galacticraft server occupies 62% of the memory.
Extra Planets-1.12.2-0.4.6 was added the day before yesterday.
Basically all players haven’t reached the 4th Rocket yet.
Even if there are only three people, TPS is around 13
This is timings analysis report.
Https://timings.aikar.co/?Id=35f690060ce94488862ccea2430be19a
Sponge time (about 3-4 minutes)
What can I do to eliminate latency or improve the server?
Sorry, my mother tongue is not English. Ask for help


#2

The sponge configuration file has only been modified
Keep-spawn-loaded = false


#3

You’re using Paper and thus the Paper forums would be more adapted to help you. Anyway, it seems to be related to the numerous hoppers in your world “town”.


#4

hopper???
Hello, I’ve cleared most funnels, but TPS still doesn’t work.


#5

There seems to be some confusion. You are saying that you are running Sponge, however the log you provided says your running a Bukkit implementation (probably paper).

Did you provide the correct log?


#6

I’m really running sponge.

Sorry, I really don’t know where you saw the Bukkit end.

My sponge version is spongeforge-1.12.2-2705-7.1.0-BETA-3361.jar


#7

Maybe the Timings report has bugged. Try generating a new one. A Spark report can also be a good alternative. To finish, as MoseMister said, a copy of your logs (using a service such as pastebin.com) might help us.


#8

The record has been lost. Wait for the next time.