[Solved] Having trouble setting up and compiling plugin

Hey Sponge community!

I came back to Minecraft programming after my last activity was in Bukket. Installed IntelliJ and wrote simple test plugin, but I can’t quite get the hang of setting the thing up. Would appreciate it if someone will link me to a good instructive video or will upload an example IntelliJ project :smile:

Thanks and keep up the good work!

Sponge Plugin Programming | IntelliJ: Setup Using Gradle - YouTube Is a good series to learn sponge under IntelliJ

There are also some recent ones by Sibomots, linked from the SpongeDocs Plugin Tutorials.

This video is heavily outdated; e.g. it uses capital letters in the plugin ID and uses the @Subscribe annotation. We really don’t want the equivalent of Bukkit’s BcBroz.

Edit: The video you linked is outdated. However, the dude’s channel has updated videos, and has uploaded videos as recently as five hours ago. This actually looks like a great resource, my b.

I tried following all these videos and it didn’t work. Any chance one of you can upload a .idea file?

Better you learn what it is you’re doing wrong. Describe your exact steps, what you expect to happen, and what happened instead.

Well, I tried whatever I could on IntelliJ but nothing that he videos taught me quite worked, so I moved to eclipse and now when I am nearly there I got this:

:compileJava FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:compileJava’.
    Could not find tools.jar. Please check that C:\Program Files\Java\jre1.8.0_121 contains a valid JDK installation.

Well umm… that’s your problem. You need a JDK (Java Development Kit), not a JRE (Java Runtime Enviroment)… either the path is pointing to the wrong folder, or you haven’t installed the JDK…

Tried changing the path, I am reinstalling the JDK and JRE

Now nothing works, and I am still struggling here :cry:
Could someone upload a .idea template? I can’t wait to get to actual programming

A specific error message and a list of the things you have done are needed to help you.

If the JDK isn’t installed or setup wrongly a .idea-file won’t help.

Hey Guys,

Thanks for the support, I finally managed to work out eclipse and my plugin practices are advancing rapidly :smile:

If anyone has trouble with eclipse he/she are welcome to contact me on the forums, I did too much research and can probably help :slight_smile:

I don’t think I can close threads, but this one’s done.