[Solved] Help with Creating Worlds

I am using my WorldHandler class and whenever i create the world, its fine but when i Join it it spams the console with this error.

When you just change the type of a world, it doesn’t change the way the world is generated.
You also need to change the generator to the required option:

    WorldBuilder builder = game.getRegistry().getWorldBuilder();
    builder.dimensionType(DimensionTypes.NETHER);
    builder.generator(GeneratorTypes.NETHER);

This code generates a “real” nether world for me.
Edit: sry cant seem to get the code formatting right.

1 Like

Fixed issue #2 but the main issue is still there.

Hmm. I dont really know what is causing this. Can you show me the rest of your code?
The error appears when you teleport to the world? Or when you join the server in general?

When you join the newly created world. The whole project is on github here

This code works for me: World creation and teleportation · GitHub
Maybe try creating your worlds differently?
Edit: the teleport code seems to be fine. I think it may be the way you create your dimensions in the Create subcommand class.

im trying some things now ill let you know.

What name are you giving the world? Maybe it’s invalid. Just a guess.

i fixed it now, im just wondering how to delete the world now, i know theres an unloadWorld method but how would i delete the world files? do i have to actually grab the world folder and delete it?

There currently isn’t a way, however there is a PR which adds the methods you need
https://github.com/SpongePowered/SpongeAPI/pull/751

2 Likes

OMG thats solid gold right there

1 Like