[Solved] Launch.bat doesn't works

Hi, I’m trying to create a sponge server but when i’m launching “lauch.bat” with this command inside :

java -Xms1G -Xmx2G -jar Sponge.jar
pause

I renamed “forge-1.8-XYZ-universal.jar” in “Sponge.jar”

The cmd say :

C:\Users\Laszlo\Desktop\Serveur Minecraft Sponge>java -Xms1G -Xmx2G -jar Sponge.jar
aucun attribut manifest principal dans Sponge.jar

C:\Users\Laszlo\Desktop\Serveur Minecraft Sponge>pause
Appuyez sur une touche pour continuer…

So i tried to lauch this in the same folder ; on the Desktop and at C:\ but that doesn’t works can you help me please.

Cordially, Diamentis.

Don’t rename it, keep it the same. Just download the forge installer, choose server and bam it will install nice and easy for you. Then download the sponge JAR and put it under ~/<forge-server-folder>/mods/.

EDIT: Please follow: https://docs.spongepowered.org/en/server/getting-started/installation.html

1 Like

Sponge for Forge is not a standalone server file; it is a mod for Forge. Download Forge, place Sponge in the mods folder, and start Forge with your start script instead. Detailed instructions can be found on the Sponge Docs :smile:

PS. There’s also a French version, but it’s not 100 % translated yet.

EDIT: Ninjaed by wingz. Ah well.

1 Like

Good point on the alt-language and links though!

2 Likes

Ok, thank you guys i followed your advices and the server is working !

Thank you very much !

2 Likes