[Solved]Server error no console output in eclipse

Hey I pulled the latest Sponge vanilla repo today (My old one was horribly outdated so i’m not sure when this error has started) and have been getting Appender Console Null pointers.

The errors are here : http://pastebin.com/szBmZA58

The output prints to log files fine (Excluding the errors)

I was wondering if anyone knew the fix for this?

Thanks
Chris Mack

@ChrisMack
I would suggest using SpongeForge, SpongeVanilla is considerably less stable.

Could you provide the full server log?

That doesn’t help us fix bugs with SpongeVanilla to make it more stable…

4 Likes

Sure thing.

Here is the Log file : http://pastebin.com/gN3T7Nir
Here is the console log : http://pastebin.com/NkYPAWGy

@ChrisMack Thank you for your report! I’ve opened an issue on the SpongeVanilla repo for this and will look into a fix soon:

SpongeVanilla is pretty stable already, pretty much the only thing it is less stable in are rare cases like this one that don’t get noticed as fast as on SpongeForge because there are less people currently using (and testing!) SpongeVanilla. However, there is no need to suggest against using SpongeVanilla if no Forge mods are needed.

1 Like

@ChrisMack Should be fixed in the latest build, would you mind pulling from GitHub and trying the new version?

For reference:

1 Like

@Minecrell Yeah that seems to have solved it thank you :slight_smile:

1 Like