[SOLVED] SpongeForge doesn't load with Forge+LiteLoader (MC1.12.2)


#1

SpongeForge doesn’t make the client crash, it just simply doesn’t load. When I use a forge version without liteloader, it works fine, but when I use a version with forge and liteloader, spongeforge doesn’t load. Does anyone know why this is? Is there something I can do to fix it or is it a compatibility issue?

Edit: https://pastebin.com/r0F1Kqn1


#2

Could you send a log? That way we have more of an idea of whats going wrong.


#3

Yes, it’s in the OP now.


#4

There is a crash. A mixen crash. This can sometimes be fixed by bootstrapping sponge (there is a mod called Sponge Bootstep) or you could also try renaming spongeforge to something that would boot first, such as aSpongeForge

Caused by: org.spongepowered.asm.launch.MixinInitialisationError: Required mixin config mixins.common.api.json requires mixin subsystem version 0.7.10

#5

Still doesn’t load: https://pastebin.com/EX70kZfn


#6
[13:07:19] [main/WARN]: Mixin config mixins.common.api.json requires mixin subsystem version 0.7.10 but 0.7.5 was found. The mixin config will not be applied.

Something is out of date. Try updating both sponge and liteloader.


#7

That’s spongeforge that’s out of date. I’ve been looking for a sponge forge that says 0.7.10, but have yet to find it… Why do I need 0.7.10 anyway? What’s wrong with 0.7.5? Where can I get a spongeforge version with subsystem version 0.7.10?

[13:07:19] [main/INFO]: SpongePowered MIXIN Subsystem Version=0.7.5


#8

Forge and Spongeforge is at/for version forge v14.23.5.2768, liteloader is the only thing I can think might be using mixin v0.7.10, but I have no idea if there was a version of Liteloader that used v0.7.5.


#9

Other way around. Liteloader is using 0.7.5, SF uses 0.7.11. Liteloader is being loaded first - this means that it’s version of Mixin is loaded rather that SF’s. SF needs 0.7.10 to load some mixins - hence the error.

Unfortunately, I don’t know how to force SF to load first on a Liteloader client - not something I’ve done myself.


#10

I figured it out. I just needed to update forge and put liteloader in my mods folder instead of installing it, because the forge developers already addressed the issue.