[SOLVED] Switched to CloudFlare; Cant use SSH or my ZNC

Any help?

Literally all I have done is switched to using CloudFlare. What do I need to do/configure to get into my server via SSH (puTTY)?

Do you know what Cloudflare is? Well, it’s many things; namely, a Reverse Proxy.

You’re probably using your domain name. However, using Cloudflare, that doesn’t point to your actual IP address. Either don’t route that specific (sub)domain through Cloudflare (you can turn that off in your DNS settings), or use the IP address itself.

1 Like

Alright, I’ll try that.

@FerusGrim that worked!

Sorry, I’m just not very experienced in this kind of stuff :frowning: Learning though!

1 Like

Something you need to keep in mind. If you compiled nginx yourself (I’m assuming you’re using nginx, because it’s awesome), you may need to re-compile it with the http_real_ip module. Then, in your nginx.conf before the configuration which pull up the conf.d and sites-enabled includes, use this page to make sure that the IPs are being correctly reported to your website.

It might also be of help to realize that when you have cloudflare enabled on a subdomain (e.g. orange cloud, not gray) that you can’t use any other port. if you need to use those ports, make another sub domain, or turn cloudflare off.

EDIT: It’s also worth going through thier docs to learn more about using them.

What? You can still access specific ports when Cloudflare is enabled on a (sub)domain. Just because you don’t see it doesn’t mean that you’re not accessing your website through port 80/443. You can specify any port you want, assuming something is listening on it.