Sponge Forge, Maybe Nucleus?

I created a new world within my server so I have my Hub world, and then the survival world. Everything is spawning in the hub world. But I can’t get the same stuff to spawn in the Survival world. I put the dimension id’s in the configs to allow it to generate in that world. However it isn’t working. Please help? I noticed that when you create a new world instead of using the normal level.dat it uses sponge_level.dat. Anyone know how to fix this? I’m doing this with my modpack.

Which stuff, and which config files? Are you referring to mod-created entities? Some will only spawn in the main overworld, because that’s the way some mods are hard-coded. More information is needed.

Mods like Roguelike, and applied energistics 2, also End: Reborn. They all have configs where I can “whitelist” the dimensions where the structures spawn. Atm they are only wanting to spawn in the main world. Even though I gave them the ability to spawn in the survival overworld.

I still haven’t figured it out.

The only thing I can think of is to check the dimension ID’s are correct via Nucleus. You could also use NBTeditor to inspect the level.dat and see what the settings are, in case something helpful like “spawn-structures” is set to false.
It’s also possible something in Sponge isn’t performing to spec, so you could try an earlier version.

Upon dabbling further, because I am convinced that it has to do with sponge, do you think structure generation could have something to do in sponge’s global.config I found a whole bunch of settings regarding structures, but I am too scared to mess with it.

P.S. I tried the NBTExplorer thing 2 days ago, it hasn’t worked. It has the correct DimensionID’s

    # Handles structures that are saved to disk. Certain structures can take up large amounts 
    # of disk space for very large maps and the data for these structures is only needed while the 
    # world around them is generating. Disabling saving of these structures can save disk space and 
    # time during saves if your world is already fully generated. 
    # Warning: disabling structure saving will break the vanilla locate command.
    structure-saving {
        # If 'true', newly discovered structures will be added to this config
        # with a default value of 'true'. This is useful for finding out
        # potentially what structures are being saved from various mods, and
        # allowing those structures to be selectively disabled.
        # If 'false', disables the modification to prevent certain structures
        # from saving to the world's data folder. If you wish to prevent certain
        # structures from saving, leave this "enabled=true". When 'true', the
        # modification allows for specific 'named' structures to NOT be saved to
        # disk. Examples of some structures that are costly and somewhat irrelivent
        # is 'mineshaft's, as they build several structures and save, even after
        # finished generating.
        # Per-mod overrides. Refer to the minecraft default mod for example.
        mods {
            minecraft {
                # If 'false', this mod will never save its structures. This may
                # break some mod functionalities when requesting to locate their
                # structures in a World. If true, allows structures not overridden
                # in the section below to be saved by default. If you wish to find
                # a structure to prevent it being saved, enable 'auto-populate' and
                # restart the server/world instance.
                # Per structure override. Having the value of 'false' will prevent
                # that specific named structure from saving.
                structures {

It should be safe to set it to auto-populate, that’s just book-keeping; it will create a list of saved structures. You could run that for a while and see if anything turns up.
Note: if you do edit the config, make sure it saves (offline or by command).

Okay, but will it fix the structures not loading? The only reason I keep pushing for this issue is because I have a dedicated server for my modpack, and a few people are stuck because they cannot progress.

I fixed the issue.