Sponge Unable to Identify SlotMachines 1.4.1

Hello,

For reference, I am running SpongeForge 1.12.2-2838-7.1.8, and every plugin/mod is working together smoothly, except SlotMachines. I have the most recent version from here: https://ore.spongepowered.org/me4502/SlotMachines/versions

The only related message I get in the server console is this, and it’s only when I restart the server:

30.12 11:49:18 [Server] Server thread/WARN [Sponge]: slotmachines: It is no longer required to include the plugin id when specifying a Key id through Key.Builder#id. This is deprecated and may be removed later. The plugin id will be retrieved from the current PluginContainer in the cause stack. Key: slotmachines:slotmachineowner

I tried contacting the developer, so I’m still waiting on word from him, but I was wondering how I could get Sponge or the plugin to recognize each other.

Thanks,
Luke

As its a sponge plugin. It should work. As you are getting that message it means that the plugin is initialising. Check the command

/Sponge plugins

If you can see it in there then sponge has done its part of booting the plugin meaning its most likely a plugin issue.

Also could you send your server log on pastebin with the link here, so we can get all the information right away.

As for that message, all that is saying is the plugin is trying to do something that was required for API 7.1 snapshot but has been removed by sponge at a later date. Because sponge is fully backwards compatible with older versions in the same major version, then it doesnt matter that your getting that message, its mainly for developers

Sorry for the late reply, here’s the pastebin: https://pastebin.com/gHX3jFNc

Also, I tried /sponge plugins, and it recognized SlotMachines. I still can’t build them though. I have the right permissions that the dev posted on his ore page.

So log wise, all looks normal. So it is a plugin issue or user issue. Hopefully the developer replies.