Sponge won't load even after following docs to the dot


#1

Hello everyone!
I’ve ran many modded minecraft servers (namely 1.7.10) but decided for our communities next play through, we should run a 1.12.2 modpack and get some cool plugins. I decided that Sponge would be the best option, although, I can’t seem to do it. I don’t even know what the issue could be to be honest.
latest.log
(Can’t share debug.log because it’s 18 MB)
serverstart.log
java -version output:
openjdk version “1.8.0_191”
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-2ubuntu0.18.04.1-b12)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)
The modpack is All The Mods 3.
Thanks in advance!


#2

I suggest starting with these two workarounds:

A mod is loading an outdated Mixin version before Sponge, please report it to the 
mod author! For temporary solution rename the SpongeForge jar file, so it's sorted 
alphabetically before the other mod e.g. rename `spongeforge-1.12.2-2705-7.1.0-BETA-3318.jar` 
to `_aspongeforge-1.12.2-2705-7.1.0-BETA-3318.jar`

Both SpongeForge and FoamFix add various optimizations that may not work with each 
other! Disable the following settings in `config/foamfix.cfg`

`B:optimizedBlockPos=false`
`B:patchChunkSerialization=false`

Please post whether or not these worked for you.


#3

That worked! Thank you!