SpongeForge crashes server with only SpongeForge mod


#1

---- Minecraft Crash Report ----

WARNING: coremods are present:
SpongeCoremod (spongeforge-1.12.2-2705-8.0.0-BETA-3273.jar)
Contact their authors BEFORE contacting forge

// You should try our sister game, Minceraft!

Time: 07/07/18 16:51
Description: Exception in server tick loop

java.lang.ExceptionInInitializerError
at org.spongepowered.common.registry.CommonModuleRegistry.registerCommonModules(CommonModuleRegistry.java:534)
at org.spongepowered.common.registry.CommonModuleRegistry.registerDefaultModules(CommonModuleRegistry.java:288)
at org.spongepowered.common.registry.SpongeGameRegistry.preRegistryInit(SpongeGameRegistry.java:167)
at org.spongepowered.mod.SpongeMod.(SpongeMod.java:155)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at net.minecraftforge.fml.common.Loader.identifyMods(Loader.java:377)
at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:566)
at net.minecraftforge.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:97)
at net.minecraftforge.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:332)
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:125)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:486)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.UnsupportedOperationException: A method was invoked on a dummy class, due to the static field EMPTY not being initialized (most likely in a CatalogType-related class).
Method: public abstract org.spongepowered.api.advancement.criteria.AdvancementCriterion org.spongepowered.api.advancement.criteria.AdvancementCriterion.or(java.lang.Iterable)
at org.spongepowered.api.util.dummy.AdvancementCriterion$DummyClass.or(Unknown Source)
at org.spongepowered.api.advancement.criteria.OrCriterion.of(OrCriterion.java:60)
at net.minecraft.advancements.Advancement.handler$onInit$zzj000(SourceFile:684)
at net.minecraft.advancements.Advancement.(SourceFile:60)
at org.spongepowered.common.registry.type.advancement.AdvancementRegistryModule$1.(AdvancementRegistryModule.java:59)
at org.spongepowered.common.registry.type.advancement.AdvancementRegistryModule.(AdvancementRegistryModule.java:57)
… 16 more

A detailed walkthrough of the error, its code path and all known details is as follows:

– Head –
Thread: Server thread
Stacktrace:
at org.spongepowered.common.registry.CommonModuleRegistry.registerCommonModules(CommonModuleRegistry.java:534)
at org.spongepowered.common.registry.CommonModuleRegistry.registerDefaultModules(CommonModuleRegistry.java:288)
at org.spongepowered.common.registry.SpongeGameRegistry.preRegistryInit(SpongeGameRegistry.java:167)
at org.spongepowered.mod.SpongeMod.(SpongeMod.java:155)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at net.minecraftforge.fml.common.Loader.identifyMods(Loader.java:377)
at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:566)

– Sponge PhaseTracker –
Details:
Phase Stack: [Empty stack]
Stacktrace:
at net.minecraft.server.MinecraftServer.handler$onCrashReport$zjh000(MinecraftServer.java:3997)
at net.minecraft.server.MinecraftServer.func_71230_b(MinecraftServer.java:889)
at net.minecraft.server.dedicated.DedicatedServer.func_71230_b(DedicatedServer.java:370)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:558)
at java.lang.Thread.run(Unknown Source)

– System Details –
Details:
Minecraft Version: 1.12.2
Operating System: Windows 7 (amd64) version 6.1
Java Version: 1.8.0_171, Oracle Corporation
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 7611555816 bytes (7258 MB) / 8520204288 bytes (8125 MB) up to 8520204288 bytes (8125 MB)
JVM Flags: 3 total; -Xms8G -Xmx8G -XX:+UseConcMarkSweepGC
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP 9.42 Powered by Forge 14.23.4.2705 5 mods loaded, 0 mods active
States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored

| State | ID        | Version                | Source                                      | Signature                                |
|:----- |:--------- |:---------------------- |:------------------------------------------- |:---------------------------------------- |
|       | minecraft | 1.12.2                 | minecraft.jar                               | None                                     |
|       | mcp       | 9.42                   | minecraft.jar                               | None                                     |
|       | FML       | 8.0.99.99              | forge.jar                                   | e3c3d50c7c986df74c645c0ac54639741c90a557 |
|       | forge     | 14.23.4.2705           | forge.jar                                   | e3c3d50c7c986df74c645c0ac54639741c90a557 |
|       | spongeapi | 8.0.0-SNAPSHOT-b0ed242 | spongeforge-1.12.2-2705-8.0.0-BETA-3273.jar | None                                     |

Loaded coremods (and transformers): 

SpongeCoremod (spongeforge-1.12.2-2705-8.0.0-BETA-3273.jar)
org.spongepowered.common.launch.transformer.SpongeSuperclassTransformer
Profiler Position: N/A (disabled)
Is Modded: Definitely; Server brand changed to ‘fml,forge,sponge’
Type: Dedicated Server (map_server.txt)

Only has the spongeForge mod and it crashes on startup


#2

So first off, last I checked API 8 was still very broken…
Second, in the future please use a service like Gist or Pastebin to upload your error.
Third, please upload the FULL logs to said service ^.


#3

Not the OP, but this is the full log as I have this exact issue too.


#4

Hello,

This issue has been reported in SpongeCommon and happens since the latest SpongeCommon update - bringing some advancements-related changes - in both API 7 and API 8 versions.

I don’t know if a fix is in the works, but using the previous SpongeForge build for now seems fine :wink:


#5

Issues have been fixed, though the SpongePowered downloads site for SpongeForge are having issues uploading binaries. Use forge’s download site for now.