SpongeForge does not recognize any Plugin

Greetings Everyone,

I have just migrated my server from Forge with mods to SpongeForge with mods by placing the spongeforge-1.12.2-2838-7.1.8.jar into the “/mods” folder. As I’ve seen in the logs the Sponge does load (I don’t know if correctly because I have never setup Sponge) but the Sponge does throw some messages in the log and it tells that its loaded.

The thing is the plugins does not load or they’re even recognized by SpongeForge, I tried installing them on the folder /mods/plugins and in just /mods.

When i Install them on /mods/plugins it does not show any messages in logs and when i do install them in /mods it pops a messages in the logs implying that for example “doot.jar is not a mod and it may cause some issue”. Tried to test some of the commands that the Plugins features on, but none works.

I leave the servers logs here https://pastebin.com/rBvdNjFR

I’m using “forge-1.12.2-14.23.5.2838-universal.jar” to fit the version of Sponge “spongeforge-1.12.2-2838-7.1.8.jar”.

Any help regarding this?

[16:01:13] [main/WARN] [mixin]: Mixin config mixins.common.api.json requires mixin subsystem version 0.7.10 but 0.7.4 was found. The mixin config will not be applied.

Sponge isn’t being applied because another mod uses an older version of mixin and is loaded first. Rename your Sponge jar to start with aaa or something like that to force it to be loaded first, and thus, load its Mixin version first. This shouldn’t break the other mod(s) that include Mixin.

1 Like

It did work, The global.cfg was created correctly so i could do the config of the paths to load the plugins from. Thank you for the help