SpongePls [BungeeCord Forge Support]


#66

Hi, I’m trying to use this plugin. Currently I’m using your latest build 1.1 SNAPSHOT b#35

I have followed the documentation you have provided. I have a forge server set up with the following config:

Forge Config:

max-tick-time=60000
generator-settings=
force-gamemode=false
allow-nether=true
gamemode=0
enable-query=false
player-idle-timeout=0
difficulty=1
spawn-monsters=true
op-permission-level=4
pvp=true
snooper-enabled=true
level-type=DEFAULT
hardcore=false
enable-command-block=true
max-players=20
network-compression-threshold=256
resource-pack-sha1=
max-world-size=29999984
server-port=25568
server-ip=
spawn-npcs=true
allow-flight=false
level-name=world
view-distance=10
resource-pack=
spawn-animals=true
white-list=false
generate-structures=true
online-mode=false
max-build-height=256
level-seed=
prevent-proxy-connections=false
use-native-transport=true
enable-rcon=false
motd=A Minecraft Server

Bungee Config:

groups:
  kmccmk9:
  - admin
servers:
  lobby:
    motd: '&1K9 Minecraft!'
    address: localhost:25566
    restricted: false
  vanilla:
    motd: '&1K9 Minecraft - Vanilla!'
    address: localhost:25567
    restricted: false
  pixelmon:
    motd: '&1K9 Minecraft - Pixelmon!'
    address: localhost:25568
    restricted: false
timeout: 30000
player_limit: -1
default_server: Lobby
listeners:
- query_port: 25577
  motd: '&1K9 Minecraft!'
  tab_list: GLOBAL_PING
  query_enabled: true
  proxy_protocol: false
  forced_hosts:
    pvp.md-5.net: pvp
  ping_passthrough: false
  priorities:
  - lobby
  bind_local_address: true
  host: 0.0.0.0:25565
  max_players: 6
  tab_size: 60
  force_default_server: true
prevent_proxy_connections: false
permissions:
  default:
  - bungeecord.command.server
  - bungeecord.command.list
  - bungeeconnector.use
  admin:
  - bungeecord.command.alert
  - bungeecord.command.end
  - bungeecord.command.ip
  - bungeecord.command.reload
  - bungeecord.command.send
  - bungeeconnector.*
online_mode: true
log_commands: false
disabled_commands:
- disabledcommandhere
connection_throttle: 4000

SpongePls Config:

#####################################
# SpongePls coniguration. YAML ONLY #
#####################################

allowed-servers:
  - 'pixelmon'

Now in game, in my lobby I try to go to the pixelmon server and nothing happens. No errors within game, no errors within console of Pixelmon Forge server. The only thing I do see within Bungee is:

16:53:29 [INFO] [SpongePls] Using the Forge Server Connector for kmccmk9
16:53:29 [INFO] [SpongePls]  for the target "pixelmon".
16:53:29 [INFO] [kmccmk9] <-> ServerConnector [pixelmon] has connected
16:53:29 [INFO] [kmccmk9] <-> ServerConnector [pixelmon] has disconnected

Obviously from this log it looks like it properly detected I wanted to go to a Forge enabled server but couldn’t establish a connection. I’m kinda stumped at this point as to where I’m going wrong. Any help would be appreciated. Again no other errors anywhere.


#67

make sure you enabled the BungeeCord related settings on the gameserver in config/sponge/global.conf
specifically the BungeeCord module and ip-forwarding


#68

Thanks for replying! After making the two changes you suggested, it started to work as expected. Thank you very much!


#69

@phit i’ve the same issue but i’ve all activated :confused: what can i do?