The server wont start


#1

so me and a few mates decided to make ourselves a modpack and want to open it up to the public, but to do so we decided we need plugins, so i was referred to spongeforge for the plugins. I tested it in a non modded forge server before adding it to our packs server to get a feel for it without needing to take down the real server, but when adding it to the real server i get an error log that according to a friend of mine says that its a mismatch version, i want to put the crash log up here and try to get a second opinion from it because im not quite sure whats going on, ive tried getting the latest of both forge and sponge forge, i tried the recommended versions of both and nothing, both of them crashed and apparently spat out the same error log. I’m running the server on 1.12.2


#2

Please upload the debug.log file to a service like pastebin or gist and we’ll try to help.


#3
<script src="https://gist.github.com/The-Doctor77/6a00bc0386e790fcf8cb139bbc82dabc.js"></script>

(note: if that doesn’t work i apologise, im quite new to all this stuff, other wise if it does work than that should be the debug.log file)


#4

i apologise, this should work


#5
  1. Is anything in particular actually not working?
  2. It looks like the mod enderiointegrationtic (Ender IO Integration with Tinkers’ Construct) might be failing to load properly. I would recommend seeing if there is a newer/older version available, and if not, remove the mod.

#6

idk what you mean by particular? sponge just isn’t loading when other mods are present, when i remove mods it works fine, plugins and all, but when i add mods it stops working.


#7

Is that log file of when everything is present? Searching through the log i see no mention of the server even trying to load Sponge


#8

im pretty sure that everything is present including sponge, because thats the log file after the server crashed, the server is working fine now that i took sponge out


#9

Lines 23-118 of the log file you linked. Where did you download the spongeforge jar from?


#10

from this site, it was the latest recommended build for forge 2768.