Voxel Sniper not working on SpongeForge

Hello there ^.^! This is my first post on the forum :slightly_smiling: I’ve been trying to setup a sponge server to use for a large dedicated server. I am looking to port it over from Spigot. I have been able to get the server up and running on 1.8 with SpongeForge 1.8 and Forge 1.8! Voxel sniper is one of the core mods for the server and I have been unable to install it without it erroring out. I first tried using the latest build of voxel sniper 7, however, it errors out on preinitialization or something.

Crash-Report: Link to crash report
Server Log: Link to server log

I then tried running the 2 green builds before it, but they both gave the same errors about being unable to inject.

On the voxel sniper wiki it says that it may be unstable, but that it is directly compatible with sponge/forge. This is the first mod I’ve tried installing.

I was hoping someone could tell me what I need to do to get voxel sniper working!


I’m fairly sure it hasn’t been updated for the latest SpongeAPI.
@Deamon (and others) will probably do something about that in due time.