Yet Another setupDecompWorkspace Failure

Currently, HEAD of SpongeForge will not work with setupDecompWorkspace. It fails to recompile Minecraft Forge because of the javax.vecmath.Vector4f class being incorrect. Here’s the log. This log is from when I deleted the cached vecmath jar (#2 on Things I’ve tried). Gradle version 2.8.

Things I’ve tried:

  • Checking that the vecmath dependencies match between Forge and Sponge (both 1.5.2, :ballot_box_with_check:)
  • Removing the cached vecmath jar so it is re-downloaded (re-downloaded correctly :ballot_box_with_check:)
  • Opening the freshly downloaded vecmath jar in JD-GUI and inspecting that for setW (it has it :ballot_box_with_check:)
  • Checking literally everything on the classpath that is a JAR for vecmath (nothing has the vecmath classes but vecmath :ballot_box_with_check:)
  • gradle cleanCache and setupDecompWorkspace (did nothing, but it did redownload whatever it needed :ballot_box_with_check:)
  • git cone --recursive [email protected]:SpongePowered/SpongeForge SpongeFresh && cd SpongeFresh && gradle cleanCache && gradle setupDecompWorkspace (failed; log :ballot_box_with_check:)

Frankly, I’m stumped. Help?

1 Like