1.8 SpongeForge!


#1

Can we all get SPONGEFORGE 1.8!


#2

It’s available right here:

Please note that builds for 1.8 and 1.8.9 are no longer supported. It was long ago, the API and implementation was incomplete in many places.


#3

It’s also helpful to a lot of people to try and use the newest version of the game possible.


#4

But my kids and 1.8.9 is the last release with original combat I know there are small changes but still ,lots of kids don’t even work for that yet


#5

Mods frickin mods not kids mods stupid auto correct