Biomes o plenty nether and end not generating


#1

I help mod a server on deploys.io and I’m trying to figure out why the nether biomes will generate but NOT with any plants or deocrations, just the base block. I ported the world and info to single player, was able to delete the nether dimension folder and reload it, and it generated perfectly! But on the multiplayer server nothings working.

We think it might be sponge related but can’t find a fix. Please help ;-;

edit: it might be nucleus, i still cant tell


#2

How do you mean nothing works? Does the server crash? If so got a crash log?


#3

nothing as in none of the fixes we have tried

im starting to believe the issue is with nucleus, the end and nether have not genereated with biomes o plenty, just default. that may be the issue

we can still do everything on the server, i just want the biomes to correctly show in the nether


#4

Have you set the level type in server properties to BIOMESOP? If not, new worlds will be vanilla by default. If you create worlds by using commands, you need to set the generator type to biomesoplenty.

On a side note, BOP’s End Biomes are “Coming soon in Minecraft 1.13!”.


#5

yeah, the overworld is all biomes o plenty, i remade a nether biome with BIOMESOP and it just generated nether hives but no biomes, for the end the biome essence and amythest wont spawn. single player it all works fine so its an issue with a plugin.

ill try to remake another world and try that. thank you for the response tho

level-type=BIOMESOP


#6

so the nether that generated when we first built the portal has the blocks (mycellium netherack, flesh block, ash block, etc) but no “decorations” (hellbark, blue fire, hives) along with the name of each biome appearing in f3 / minimap stuff.

remaking a world with the generator set to BIOMESOP makes all the biomes hell, but there is nether hives. thaumcraft crystals also spawn in this one.

the commands ive tried are:
/world create -g biomesoplenty:b_i_o_m_e_s_o_p -d nether nethertest

/world create -p minecraft:the_nether -g biomesoplenty:b_i_o_m_e_s_o_p -d nether nethertest2

/world create -p minecraft:the_nether -g biomesoplenty:b_i_o_m_e_s_o_p -d DIM-1 nethertest3


#7

i managed to fix it!

i cant remeber exact, but i did something like this

/world create -g biomesoplenty:b_i_o_m_e_s_o_p -d biomesoplenty:nether nethertest


#8

i can confirm, to fix this adding to the server.properties file generator type: biomesoplenty:b_i_o_m_e_s_o_p

then deleting and reseting the nether and end does fix the issue… i hope anyone who comes across this can also find their peace