Bug issue - i need help


#1

Hello,

I have a big probleme when i try to running this command : /angry or /ameno

I use sponge 1.12.2 (7.1.0-BETA-3392 / Forge 14.23.4.2705)

I get this error :

[22:02:48] [Server thread/INFO] [nucleus]: Xerosta ran the command: /ameno
[22:02:48] [Server thread/ERROR] [Sponge]: Error occurred while executing command ‘ameno’ for source EntityPlayerMP[‘Xerosta’/657, l=‘Lobby’, x=-479.39, y=3.00, z=-350.60]: org.spongepowered.mod.plugin.SpongeModPluginContainer cannot be cast to net.minecraft.entity.player.EntityPlayerMP
java.lang.ClassCastException: org.spongepowered.mod.plugin.SpongeModPluginContainer cannot be cast to net.minecraft.entity.player.EntityPlayerMP
at org.spongepowered.mod.event.SpongeToForgeEventFactory.createAndPostServerChatEvent(SpongeToForgeEventFactory.java:309) ~[SpongeToForgeEventFactory.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.mod.event.SpongeToForgeEventFactory.createAndPostForgeEvent(SpongeToForgeEventFactory.java:240) ~[SpongeToForgeEventFactory.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:338) ~[SpongeModEventManager.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.mod.event.SpongeModEventManager.extendedPost(SpongeModEventManager.java:435) ~[SpongeModEventManager.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:404) ~[SpongeModEventManager.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.common.event.SpongeEventManager.post(SpongeEventManager.java:447) ~[SpongeEventManager.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.common.SpongeImpl.postEvent(SpongeImpl.java:225) ~[SpongeImpl.class:1.12.2-2705-7.1.0-BETA-3392]
at net.minecraft.entity.player.EntityPlayerMP.simulateChat(EntityPlayerMP.java:4664) ~[oq.class:?]
at hdr.commands.AmenoCMD.execute(AmenoCMD.java:16) ~[AmenoCMD.class:?]
at org.spongepowered.api.command.spec.CommandSpec.process(CommandSpec.java:388) ~[CommandSpec.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.api.command.dispatcher.SimpleDispatcher.process(SimpleDispatcher.java:341) ~[SimpleDispatcher.class:1.12.2-2705-7.1.0-BETA-3392]
at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:329) [SpongeCommandManager.class:1.12.2-2705-7.1.0-BETA-3392]
at net.minecraft.command.ServerCommandManager.func_71556_a(SourceFile:1083) [dh.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147361_d(NetHandlerPlayServer.java:958) [pa.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147354_a(NetHandlerPlayServer.java:937) [pa.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:37) [la.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:9) [la.class:?]
at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:92) [PacketUtil.class:1.12.2-2705-7.1.0-BETA-3392]
at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$zle000(SourceFile:539) [hv$1.class:?]
at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [hv$1.class:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_72]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_72]
at net.minecraft.util.Util.func_181617_a(SourceFile:46) [h.class:?]
at org.spongepowered.common.SpongeImplHooks.onUtilRunTask(SpongeImplHooks.java:293) [SpongeImplHooks.class:1.12.2-2705-7.1.0-BETA-3392]
at net.minecraft.server.MinecraftServer.redirect$onRun$zjj000(MinecraftServer.java:3972) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:723) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:396) [nz.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:668) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:526) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72]

Thank you in advance


#2

This isn’t from Sponge, you will need to report the issue to the developer of the plugin/ mod which supplies that command.

~ Alice


#3

Okay Thanks you Alice.
Sorry for the disturbance and spelling mistakes because I am french, and I didn’t use Google traduction :joy: .


#4

I have another question

whats version for my serveur is best :
Sponge Forge 7.1.0 BETA 3392
OR
Sponge Forge 7.1.0 BETA 3361

Thanks you in advance.
@yepidoodles


#5

Depends really, using the stable build is more sensible in some cases, but using the most recent means that more bugs are fixed (but also more could have occured), and also some plugins always build to the latest version, instead of the stable. So it’s a personal choice. Although I personally always update to the latest build.

~ Alice


#6

Okay, Thanks for your help !