Cannot start Enigmatica 2 server with Sponge


#1

I’m trying to set up an Enigmatica 2 server with Spongeforge so I can integrate it into a BungeeCord network but the server refuses to launch with SpongeForge installed.

Currently I am running:

Enigmatica 2 1.67d
forge-1.12.2-14.23.5.2825-universal.jar
spongeforge-1.12.2-2825-7.1.6.jar
SpongeBootstrap-0.7.0.jar

As I read in other topics, I have removed Phosphor.

I have made the following edits to foamfix.cfg:

B:optimizedBlockPos=false
B:patchChunkSerialization=false

To no avail the server crashes. It does not generate a crash report, but here is a pastebin of the latest.log
https://pastebin.com/DXg2TiUg


#2

I tried renaming:
aaaspongeforge-1.12.2-2825-7.1.6.jar
aaSpongeBootstrap-0.7.0.jar

The result is still a crash:
https://pastebin.com/xa2rVVsb


#3

The issue is that another mod is loading before sponge is. The idea of putting the name of sponge as aaasponge is that it loads first. This means that the crash you posted on your comment is wrong, or another mod is somehow hijacking the boot priority and putting it first or something else is at play that is beyond me.


#4

I’ve been trying a number of different combinations in order to try and get something to work, though I see a common trend right now.

Currently I am using forge 2836 (packaged with the pack) with sponge 3841 with the filename renamed with _a and this is what I get
https://pastebin.com/Q4mSaAgE


#5

Bump. Has anyone figured out how to run Enigmatica 2 with sponge?


#6

I would try updating sponge and forge first, or trying to get a version of sponge that is targeting a version of forge closer to what you are running.


#7

I’ve tried using:

forge-1.12.2-14.23.5.2836-universal (packaged) with spongeforge-1.12.2-2838-7.1.7-RC3844

forge-1.12.2-14.23.5.2825-universal with spongeforge-1.12.2-2825-7.1.6

forge-1.12.2-14.23.5.2838-universal with spongeforge-1.12.2-2838-7.1.7-RC3844

and a number of other various combinations that made less sense.

I’ve tried adding _a to the filename of spongeforge

Currently, with the changes;

B:optimizedBlockPos=false
B:patchChunkSerialization=false

Phosphor removed

USE_SPONGE=1; set in settings.cfg (main directory)

and keeping the filenames the same yields me with this: https://pastebin.com/2dVR7btn

Renaming spongeforge with _a then yields me with this: https://pastebin.com/hNMRVb88


#8

You could be trying to load SpongeBootstrap as a mod. Make sure to read the instructions on the SpongeBootstrap thread (SpongeBootstrap - Fixes ordering issue with other coremods) on how to use it. Apologies if this is not the case. :smiley:


#9

Actually, I do have sponge bootstrap simply in the mods folder. I must have missed documentation pertaining to special install instructions. I really hope this is the case!


#10

Okay, I have tried to use SpongeBootstrap-0.7.0.jar as the “JAR File” in Multicraft

Main directory consists of:
forge-1.12.2-14.23.5.2836-universal.jar
minecraft_server.1.12.2.jar
SpongeBootstrap-0.7.0.jar

Mod directory has:
spongeforge-1.12.2-2825-7.1.6.jar
(I have also tried _aspongeforge-1.12.2-2825-7.1.6.jar annotation with the same result)

It still fails to launch failing at net.minecraft.util.text.TextComponentBase

https://pastebin.com/RFmRJkq6

If I try a newer version of forge/sponge:
forge-1.12.2-14.23.5.2838-universal.jar
spongeforge-1.12.2-2838-7.1.7-RC3843.jar

Failing at net.minecraft.tileentity.CommandBlockBaseLogic

https://pastebin.com/m0CBCgRq

I am completely at a loss here… I know Sponge isn’t officially supported on Enigmatica 2, but I cannot be the only one who is trying to get it working. I’m either missing something plainly obvious or it’s just… broken?

The reason I want this so much is because I already run and manage a FTB Revelation server which makes extensive use of Sponge and various plugins. Now opening an Enigmatica 2 server, without having Sponge it would either be a complete shell compared to the Revelation server, or I would have to use a vastly different method in order to achieve a similar result in terms of economy, claiming, chunkloading, etc… I also very badly want to set up a BungeeCord network, which as I understand is only possible with Forge servers while using Sponge… So…


#11

So the issue is that another mod is loading before Sponge. While renaming sponge to aaasponge and sponge bootstrap are supposed to make sponge load first, its … Well being overriden somehow. The only thing I can think of that is causing Forge to load another mod before Sponge even with Sponge bootstrap is a modified Forge that forces the loading of another mod.

Did you download forge from the official website? Or was it included in the modpack?


#12

I have tried numerous different versions of forge. The version forge-1.12.2-14.23.5.2836-universal.jar was included with the pack

Version forge-1.12.2-14.23.5.2838-universal.jar was downloaded through the official website.

Every different combination of forge/sponge that I have tried has yielded the same result, just in a slightly different way. Something is being loaded before sponge. Some way, some how.


#13

It maybe a case of trying to find the mod loading before sponge and then removing that mod. It may take some time but when you find the mod in question, the sponge community and/or the mods community will be able to solve the issue


#14

I guess I will just have to do that on the side then and let the server go live in the meantime without sponge.


#15

I’m wondering what modified launch script it’s using, that forces you to modify its’ “USE_SPONGE” setting. Have you tried launching it without a fancy script, just simple memory and launch args?


#16

I tried bypassing the complex serverstart.bat and created a simple launch script for spongebootstrap. I launched it locally as a test because I’m not sure how the remote start works through multicraft but even locally, the same result.


#17

I did it! I got it to load! After noticing that there was an update for Enigmatica 2 1.68a I decided to redo the whole server setup (locally) to continue testing. I started with a fresh server file, set the settings.cfg to USE_SPONGE=1 and dropped in SpongeBootstrap-0.7.0.jar and spongeforge-1.12.2-2838-7.1.7-RC3843. I ran the ServerStart.bat once and let it fill in needed libraries based on sponge being loaded and it made it past the point it normally failed on.

It crashed when trying to generate the world so I then took sponge back out, and ran the server once through without it to generate the world. Once that worked I dropped sponge back in, and SUCCESS!

We are loaded, and I can connect!

Bloody hell this was a nightmare.


#18

I’ve just taken a look at the issue you were having. The problem stemmed from an incompatibility with Librarian Lib and Sponge.
The issue was reported a few months ago and was recently fixed:


The updated modpack probably included this fixed version.

The actual problem is not something SpongeBootstrap is designed to fix, so unfortunately no help there.

Glad you got it sorted in the end.


[Solved] Server Crashing On Startup (Sponge not loading first?)