Can't Get Modded Item Names


I apologize if this is in the wrong forum, if it is, please let me know and I’ll move it to a more appropriate forum asap. :slight_smile:

So my problem is that the names of some modded items are not recognized. I don’t really see a way of getting the names of certain items to spawn them in. Is there a certain sponge command that I’m missing to get the proper name of certain modded items? Or is these some plugin or software I need to get the item names? If anyone has any idea about this, please let me know, thanks!

Additional details:

  • I’m running the pack All The Mods v. 1.5.8
  • I’m running SpongeForge 1.10.2-2221-5.1.0-BETA-2109

Also, really off topic, but does anyone know how to go into cheat mode with the NEI in 1.10.2? I don’t see any option to change from recipe mode to cheat mode now? If it matters, I’m using the pack All The Mods v. 1.58.

Samuel Johnson (Vigilius)

There’s a very easy way to check if this is the right forum: Does the problem persist without SpongeForge loaded? If it does, you could still potentially get support here in the off-topic section, or from forge or mod forums. If the problem goes away without Sponge, it is almost certainly a Sponge, or Sponge-related, bug, and we’ll probably need your logs.

Also, what exactly do you mean by:

Do you mean that ids are desyncing? Or that names like item.stick are showing up? Or are anvils broken? Do you mean when used in commands (like with /give)? (Maybe I’m just confused… but please clarify for me :slight_smile: )

Hi! Thank you for your response an clarification on the post location.

To clarify for you: I’m specifically talking about /give

I do not understand how to get the name of the modded items to perform the /give command.

For example, how would I get the item name to perform the /give command on an item like the Creative Energy Cube from Mekanism? Or any modded item for that matter?

What would I type?
/give Vigilius creativeenergycube?
No, because that doesn’t work.
What about, /give Vigilius mekansimcreativeenergycube?
Nope, just another invalid item name.

Hopefully this clarifies it. :slight_smile:

Ah I see… You should be able to press f3+h ingame to display “advanced tooltips” that shows item ids in grey text below the name (when you hover over the item in an inventory). I’m not 100% sure it works with mods, but it should.

Remember, it’s <modid>:<itemid>.

If it’s <modid>:<itemid>, what would be the spawn id for the Nuke from ic2?

Please tell me how you would spawn a nuke from ic2 and explain how you got it.

I just tried using ic2:te.nuke and got:

This could just be me being a total idiot, but hopefully, I can get this fixed/understand this id thing :slight_smile:

That’s not an item ID. The item ID is right at the top - ic2:te

If ic2:te is the item ID what is the mod ID?

I appreciate you trying to help me, I feel quite confused right now.

ic2 is the mod id (IndustrialCraft 2), and te is the item ID.

That’s not the id. That spawns: an “invalid” block.

Ah, there’s a data value to this. Type /give @p ic2:te 1 2

That worked! Thanks! But how did you determine that it had a data value? Can you please explain what that last number in the command means and how you found it?

The data value is the second number.
I’m not sure how you got an actual numeric id from this, however, given that it’s 1.10

So everything you’ve said has been very helpful, but there’s one last item that is stumping us.

These energy cubes all share the exact same number ID, codename, everything. The only difference between them the NBT which I haven’t seen on any other item except these. The NBT stats the cube’s Tier(1 through 4), and how much energy is currently stored in it. Could you help us figure out how we spawn a specific cube type?

That’s actually really easy… the /give command takes a bunch of optional arguments, the last of which is nbt. The information you see there under nbt is actually the exact same format you need for the command, so to summon the highlighted item, it’d be: /give @p mekanism:EnergyCube 1 0 {tier:0,mekData:{energyStored:2000000.0d}}, the command is of the form /give [player] [item id] [quantity] [metadata] [nbt]. (Though it’s possible this won’t work… I don’t know what kind of checks the /give command performs on nbt, but it should work in theory).