CompileDummy.jar and provideddummy.jar missing

Hello, so I’m doing some research on some existing plugins and I’ve come across two of them that require compileDummy.jar and provideddummy.jar as external dependencies. I’ve tried to Google them to acquire them, but had no luck. Does anyone know where these jar files can be obtained? Thanks.

I vaguely guess that these jars are from the genIntellijRuns gradle task. Though I haven’t seen them recently, maybe it is from older versions.

There should be no reason to depend on these directly. How are they even depended on? As a gradle dependency? Or in an IntelliJ run configuration?

Sorry, I should have mentioned I’m using Eclipse Photon and the projects I’m looking at use Gradle. They showed up as part of the build path. I checked the file of one of the plugins and they’re not mentioned there so I’m not too sure myself how the plugins depend on it. If it helps, one of the plugins I’m looking into that also uses these jars is PluginMixinTest, which is part of the Sponge Cookbook bundle.

Without starting Eclipse, try executing gradlew.bat build and see if it succeeds, if not please post the log.

I ran the bat files and both were successful. I re-opened Eclipse and refreshed the projects, but I’m still getting the same missing dependencies errors.

Then Eclipse is the problem. I really recommend using IntelliJ. I can’t help you further because I never used Eclipse.

1 Like

Try running gradlew.bat setupDecompWorkspace.