Crash Issue (NoSuchMethodError) [1.12.2-2838-7.1.9]

Hello guys,

I am trying to run a Life in the Industrial Village modpack with (recommended) SpongeForge 1.12.2.

Crashed at the start (see logs below).


Logs

server.log: https://paste.feed-the-beast.com/view/29d6a0a7
debug.log: https://paste.feed-the-beast.com/view/71b2a420


Some more info:

Forge Version: Forge 14.23.5.2838 (1.12.2)
Java Version: Java 8 - OpenJ9
SpongeForge Version: 1.12.2-2838-7.1.9 (recommended build)
Memory allocation pool: (min) 1gb - (max) 3gb

Server Provider

don’t want to accidentally get into trouble for advertisement so not posting here, but yes, I am running on a paid dedicated server

(advertised/claimed) Server Stats:
Processor: AMD Epyc 7351P - 2.4 GHz / 2.9 GHz
Memory: 4 GB
Disk: 20 GB NVMe (SSD)


What have I already tried:

I did read the common crash issues and tried all the solutions…

  • disabled some optimization setting in FoamFix (B:optimizedBlockPos and B:patchChunkSerialization)
    Note: FoamFix is present in the modpack

  • renamed for JAR file with an underscore in front and made sure to be the first mod in the mods directory
    Note: It did fix some different errors

  • Tried Java 10 and Java 11 as well

  • Tried with the newest version of Forge: 14.23.5.2847 (1.12.2)

So currently Mixens and Forge 1.12 does not support any java version better then Java 8, so please make sure you are running Java 8.

The error isnt ClassNotFoundException. That part of the error is a effect of the actual error. This is the actual error

java.lang.NoSuchMethodError: 
org/spongepowered/asm/launch/GlobalProperties.get(Ljava/lang/String;)Ljava/lang/Object; (loaded from file:/home/gs-40718/./mods/_spongeforge-1.12.2-2838-7.1.9.jar by sun.misc.Launcher$AppClassLoader@b4f695e6) called from class io.github.lxgaming.sledgehammer.launch.SledgehammerLaunch (loaded from jar:file:/home/gs-40718/./mods/Sledgehammer-1.12.2-1.6.5.jar!/io/github/lxgaming/sledgehammer/launch/SledgehammerLaunch.class by net.minecraft.launchwrapper.LaunchClassLoader@2bbb4a3d).

The issue is that SledgeHammerLaunch is trying to call a sponge function that either does exist anymore or exists in a newer version. Based on how new your sponge is, its probably the former.

Try removing the sledgehammer launch mod and seeing if it solves the issue. If it does then contact there devs for an update to resolve the issue (if they havent already)

Thank you for your help. Yes, indeed it was due to SledgeHammer.

Removing it solved the immediate issue, and the server managed to launch. The dev is also aware of the issue, thus he had pre-release a BETA version of the SledgeHammer that was compatible with the latest recommended SpongeForge on SledgeHammer GitHub release page (the file in question: Sledgehammer-1.12.2-2.0.0-BETA-sponge.jar).

1 Like