Crash problems "server tick took 60.00 seconds"

I have a serious problem with crashes because of TPS (?) . I have diagnostics from spark (plugin) but I dont know so much how to read that information. The main problem is a common one, " java.lang.Error: ServerHangWatchdog detected that a single server tick took 60.00 seconds (should be max 0.05) " and the diagnostic with the spark cmd /spark sampler --timeout 50 and get this: https://sparkprofiler.github.io/#s9U9sibvfg

https://sparkprofiler.github.io/#6DhqcWYiIe (second diagnostic in a different momment after a crash)

Server info :

22GB RAM hosted in fallout-hosting with spongeforge 1.12.2 and mod Pixelmon Reforged 7.2, normally about 20 players playing and 4 worlds loaded including end and nether.

I drop here some crash-reports from the last hours/days in case someone want to also check that if can help (also say anything other info that you need if you want help me and I let you know): https://pastebin.com/j4Xw1wCJ

https://pastebin.com/WiZSTyvK

https://pastebin.com/XmFa5WZw

https://pastebin.com/jT2GQNtN

When max-tick-time is -1: It sayed all the time can’t keep up and then just kicked all the players and sayed to them when trying to reconnect “You are alredy online” and console don’t do nothing except if I kill the server. https://pastebin.com/fsafbevf (console in that moment)

PD: I tryed to change max-tick-time to -1 but problem is that it keeps crashing but with -1 it also gets frozen, and don’t crash but you can’t just reconnect and it says for all players “you are alredy online”. So its not a solution for me. It’s not a solution either to change the default 60000 to 50000, 10000 or more than 60000 because it keeps crashing but says (instead of 60.00 seconds in crash-report for 60000max-tick-time) 50.00 or 10.00 or 90.00 in case I put 90000 but main problem is that it keeps crashing.

Hi. So the error is caused due to either a lot of processing to be done at once or a infinite loop due to bad coding. Normally its difficult to detect what exactly is causing it but thanks you your many logs. It looks like redprotect is causing it. Specificly the getting of regions.

The reason why you get “you are already online” when setting max server tick time to -1 is because the server is processing so much that it doesn’t respond to chances made from the client, so the client gives up and disconnects, however the server still believes your on it, resulting in “you are already online” when attempting to connect

How many red protect regions do you have?

Ok I will try to change redprotect (all users had at least 1 claim) and use GriefPrevention instead.

Grief prevention may run into the same issue. It all depends on how it processes its claims.

I have exactly the same problem. Have you solved it? @eguren7

Yes. With GriefPrevention and removing RedProtect is absolutely solved for me! It seems like GriefPrevention processes better the claims and RedProtect cause a lot of logs. GriefPrev solve this problem because processes different the claims in order to avoid crash problems.

I’ll do the same. How did you do the data migration? I’m having trouble migrating to GriefPrevention. Thanks for the help!

Don’t migrate nothing. I let the users know in order to let them a few days to protect with GP their homes