Crashing on Setup: Sponge and FTB Ultimate Reloaded


#1

Hello!

I’m in the process of setting up a FTB Ultimate Reloaded Server for my work and would like to install some plugins on it. After I did some research, I found Sponge seems to be the best option for plugins with Forge for 1.12.2 and the guides I’ve watched suggested it was as easy as putting the sponge.jar into the mods folder, but it seems I’ve got something wrong and am looking for some help.

Here is what I’ve done:

  1. Installed and set up a FTB Ultimate Reloaded Server version 1.12.2-14.23.5.2815. It works! Yay.
  2. Downloaded the most recent, stable version of Sponge (1.12.2-2768-7.1.5)
  3. Placed the spongeforge-1.12.2-2768-7.1.5.jar into the mods folder of the FTB:UR server
  4. Run the server again
  5. Server crashes with a crashlog that makes several mentions of sponge, but I can’t discern the exact issue. (I’ll link the crashlog below)
  6. Thought the issue may be that the world needed re-generated with sponge in the mods folder, so I deleted the world and restarted the server.
  7. Same crash as before. (See the crashlog below)

My thinking is that perhaps there is an issue between the Forge version of FTB:UR and the required forge version of Sponge. The FTB modpack uses Forge version 2815 and the recommended build of Sponge is for Forge 2768. I’m not sure if that is true or how to fix that, but that’s my best guess at the moment. Perhaps I’ve done something else wrong in the setup. I’d really appreciate some help.

Here is my crashlog: https://pastebin.com/Ccn6Bexq

Thanks,

Devandaheart


#2

It looks like the same problem as this: Server crashes on startup when sponge is added


#3

That appears to have fixed it! Thanks so much! I would have never known about that issue.

Cheers!