Cross Plugin Dependency Problems [SOLVED]

Hey all,

I’ve had this persistent error where two of my plugins, GeoWorld and IgneousPack, are identified by Sponge as having the same mod ID.

Now, a bit of background: GeoWorld, in addition to being a ‘master’ plugin, is also a dependency for IgneousPack as well as other plugins I might release.

after expanding the .jar file of IgneousPack, I found GeoWorld files inside, which leads me to believe this is where the mod ID error originates from.

So, how might I go about fixing this?

Are you accidentally shading in dependencies maybe? That seems like the most likely case.

Perhaps… but I’m not sure how. The and gradle.settings files are as they are in the git repos

I really don’t have too much of a clue. Maybe the simplest solution would be to just treat them like normal maven artifacts that you depend on. Use something like JitPack for example. One last attempt could be to try compileOnly instead of compile for GeoWorld.

I suppose I could restructure my projects completely, but I’ll try compileOnly first

Yep that didn’t work. Sadface.

Can you post the error that you’re getting from Sponge?

@Aaron1011 & @Katrix

So I’m using eclipse. Way before I decided to gradleize my projects, I was playing around with adding projects to the build path. I think it was probably unwise of me to start with an IDE as bloaded as Eclipse without really understanding what a build path was, or how adding another project to the classpath would affect the build. I’ve since removed the GeoWorld dependency from the buildpath, and instead have both mods depend on a third project.

Anyways, I’m betting this has to do with the ‘geoworld’ project being nested inside ‘igneouspack.jar’. I’ve tried to remedy this by changing the .jar to a .zip, removing the GeoWorld dir, and rezipping it back into a .jar, but the mod fails to load:
UE igneouspack{1.0.1a} IgneousPack (IgneousPack-0.0.1-SNAPSHOT.jar)

I’m guessing its something to do with the IDE

EDIT: Solved. I just had to delete the GeoWorld folder under my build directory for the project.